httpd server problems

Discussion in 'Installation/Configuration' started by Djunity, Nov 25, 2007.

  1. Djunity

    Djunity New Member

    Hi

    I just installed ispconfig (clean server install).
    Im having troubles to get the webserver running ok
    I have tryd several things but nothin changes, i also searched the forum but could not find a solution to the problem.

    i added a few websites in isp but the only page that can be shown is the index.html that is placed by ispconfig install.
    I uploaded a working website to the directory of the domein where it should run but im getting this error:
    Code:
    Object Not Found!
    
    The requested URL was not found on this server. If you have entered the URL manually, please check your spelling and try again.
    
    If you consider that these are server in error, please contact the webmaster.
    Error 404
    Www.galaxyhublist.com
    Apache/2.2.4 (Mandriva Linux/PREFORK-6mdv2007.1)
    No matter what i try i can seem to find the problem does anyone have an idea about whats wrong?

    Regards Djunity
     
  2. daveb

    daveb Member

  3. Djunity

    Djunity New Member

    well thats couse i switcht my router to my second server so that the site wont be offline
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at the apache error log file (the global one and the one in the websites log directory),
     
  5. Djunity

    Djunity New Member

    Hi

    Here is the last line from the httpd main error log:
    Code:
    [Sun Nov 25 19:23:12 2007] [error] [client 66.249.65.212] File does not exist: /var/www/html/hublist.php
    now i know why it aint showing any of the pages couse for all domains it goes to "/var/www/html/hublist.php" how ever for the domain www.galaxyhublist.com it should be /var/www/web6/web/* the domains do not link to there proper document root.

    Any idea what could be wrong ??

    Regards Djunity
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in Vhosts_ispconfig.conf, and what's the output of
    Code:
    ifconfig
    ?
     
  7. Djunity

    Djunity New Member

    Hi.

    vhosts
    Code:
    ###################################
    #
    # ISPConfig vHost Configuration File
    #         Version 1.0
    #
    ###################################
    #
    NameVirtualHost 80.61.151.248:80
    <VirtualHost 80.61.151.248:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.galaxyhublist.com:80
    ######################################
    #
    #
    <VirtualHost 80.61.151.248:80>
    ServerName www.galaxyhublist.com:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web6/web
    ServerAlias www.galaxyhublist.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias  /cgi-bin/ /var/www/web6/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web6/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web6/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web6/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web6/user/$1/web/$3
    </VirtualHost>

    Output off ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:18:F3:92:95:3F
              inet addr:192.168.1.67  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::218:f3ff:fe92:953f/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:45904 errors:0 dropped:0 overruns:0 frame:0
              TX packets:28243 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:4718936 (4.5 MiB)  TX bytes:13387134 (12.7 MiB)
              Interrupt:17 Base address:0xd000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:5297 errors:0 dropped:0 overruns:0 frame:0
              TX packets:5297 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:450412 (439.8 KiB)  TX bytes:450412 (439.8 KiB)
    
    Regards Djunity
     
  8. daveb

    daveb Member

    you should use your servers lan ip 192.168.1.67 in ispconfig settings not wan ip 80.61.151.248
     
  9. Djunity

    Djunity New Member

    Hi

    Here the new vhost section
    Code:
    ###################################
    #
    # ISPConfig vHost Configuration File
    #         Version 1.0
    #
    ###################################
    #
    NameVirtualHost 162.168.1.67:80
    <VirtualHost 162.168.1.67:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.galaxyhublist.com:80
    ######################################
    #
    #
    <VirtualHost [COLOR="Red"]162.168.1.67:80[/COLOR]>
    RewriteEngine on
    RewriteCond %{HTTP_HOST}   ^www.galaxyhublist.com [NC]
    RewriteRule   ^/(.*)$ /include/$1  [L]
    ServerName www.galaxyhublist.com:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web6/web
    ServerAlias www.galaxyhublist.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias  /cgi-bin/ /var/www/web6/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web6/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web6/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web6/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web6/user/$1/web/$3
    </VirtualHost>
    Pitty enought that didnt do the trick i have left the router directed the my isp server so you can see for your selfs it still dicects all requests to /var/www/html.
    Any other sudjestion ??

    Regards Djunity
     
  10. daveb

    daveb Member

    did you change your servers ip? on your ifconfig in the post before it was 192.168.1.67 and now you have 162.168.1.67 or is that just a typo?
     
  11. Djunity

    Djunity New Member

    Hi

    Nope i changed it like your said and after i changed the ip to my lan ip and after the change still nothing

    Regards Djunity
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Please take a look at the end of your main Apache configuration file. There should be a section added by the ISPConfig installer.
     
  13. Djunity

    Djunity New Member

    Hi

    Code:
    Include /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf
    That whats on the bottum of the httpd.conf file looks ok to me.

    Regards Djunity
     
  14. Djunity

    Djunity New Member

    Hi

    Anyone got another idea ??

    Regards Djunity
     
  15. daveb

    daveb Member

    what i meant was you posted your vhost file after ip update and the ip shown 162.168.1.67 is not what you posted in your previous ifconfig post as your servers ip 192.168.1.67 so I wondered if you made a typo 162 vs. 192 when entering your servers ip?
     
    Last edited: Nov 29, 2007
  16. Djunity

    Djunity New Member

    Hi

    Your totaly right was a typo from me it works now thanks for your patience only need to fix php now Thanks alot.

    Regards Djunity
     

Share This Page