httpd not found

Discussion in 'Installation/Configuration' started by guidovanh, Feb 25, 2006.

  1. guidovanh

    guidovanh Member

    On my Linux-server httpd is running (if it is not, users are unable to see my websites).
    I am trying to install ISPConfig. The setup-script says:
    httpd not found
    (my conf file is located in: /usr/local/apache/1.3.34/conf/httpd.conf)

    What can I do solve that problem?
    Last edited: Feb 25, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? Did you use one of the "Perfect Setup" guides on HowtoForge to set up the system?

    Is your Apache located in an unusual location?
    Please run
    locate httpd
    and post the output.
  3. guidovanh

    guidovanh Member

    I am using SuSE 10.

    I found and used this installation manual.

    the commands updatedb and locate httpd results in a
    command not found

    Maybe Appache is located in an unusual location, I followed the installation instruction from (the Dutch translation of) these manual (but I preferred to use the newest version of the applications).

    Thanks for help in advance.
    Last edited: Feb 26, 2006
  4. guidovanh

    guidovanh Member

    Is it possible (and recommended) to edit the setup script on such a way that the setup script find the httpd at the right place?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The setup script is searching for the httpd in the usual places defined by your path variable. If you install your httpd in another location, you will have to make a symlink.


    ln -s /path/to/my/apache/binary /usr/bin/httpd
  6. guidovanh

    guidovanh Member

    I am sorry, I don't know what a symlink is.
    As mentioned in a previous message, my apache is located in /usr/local/apache/1.3.34, so I entered:

    ln -s /usr/local/apache/1.3.34/bin /usr/bin/httpd
    When I run ISPconfig's setup again, the error message is the same: httpd not found.
  7. falko

    falko Super Moderator ISPConfig Developer

    This tutorial installs Apache in an unusual location, that's why the ISPConfig installer doesn't find it. You should use this tutorial instead:

    Please run this:
    yast -i findutils findutils-locate
    and then again
    locate httpd
    and post the output.
  8. guidovanh

    guidovanh Member

    What happens the currently installed websites into httpd.conf and vhost.conf?
    Are they installed properly after the setup procedure described in mentioned URL?

    some utils were installed...

    Here's the output:

    linux:/share/install_ispconfig # updatedb
    /usr/bin/find: /media/floppy: Geen medium gevonden
    linux:/share/install_ispconfig # locate httpd
    linux:/share/install_ispconfig #
    Hope it is clearly for you
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have already sites installed on your server with your existing, you will either have to migrate them to the new ISPConfig directory trr or you sould not Install ISPCOnfig.

    The correct symlink command for your installation will be:

    ln -s /usr/local/apache/1.3.34/bin/httpd /usr/bin/httpd
  10. guidovanh

    guidovanh Member

    Does ISPConfig provide an option to migrate the websites or can I 'simply' copy the websites to the trr directory?

    I'll try to translate what the result is of this command:
    ln: making symbolic link: '/usr/bin/httpd/httpd' to '/usr/local/apache/1.3.34/bin/httpd': file exists
  11. falko

    falko Super Moderator ISPConfig Developer

    You must create web sites first in ISPConfig, and after ISPConfig has created the appropriate directories for these web sites, you can copy over your old web sites.

    Please post the output of
    which httpd
  12. guidovanh

    guidovanh Member

    There was no output of which httpd.

    I also tell you the last few lines of the output of ISPConfig:

    ########## WEB SERVER ##########
    which: no httpd in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    which: no apache in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    which: no apache2 in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    Checking for program httpd...
    which: no httpd in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    which: no httpd2 in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    ERROR: httpd not found!
    linux:/share/install_ispconfig # which httpd
    linux:/share/install_ispconfig #
  13. falko

    falko Super Moderator ISPConfig Developer

    Please run
    rm -fr /usr/bin/httpd
    ln -s /usr/local/apache/1.3.34/bin/httpd /usr/bin/httpd
    which httpd
    What's the output?
  14. guidovanh

    guidovanh Member

    linux:/share/install_ispconfig # rm -fr /usr/bin/httpd
    linux:/share/install_ispconfig # ln -s /usr/local/apache/1.3.34/bin/httpd /usr/bin/httpd
    linux:/share/install_ispconfig # which httpd
    linux:/share/install_ispconfig #   
  15. falko

    falko Super Moderator ISPConfig Developer

    Ok, now you can try again to install ISPConfig.
  16. guidovanh

    guidovanh Member

    Falko, you are great! I think it's working now. May be there occur other problems, but for now it is working...

Share This Page