httpd fails on start with bad user name ispapps error after Perfect Server ISPconfig3

Discussion in 'HOWTO-Related Questions' started by ssscud, Jun 9, 2010.

  1. ssscud

    ssscud New Member

    Hey guys,

    I just did a full walk nice and slow with the ISP3config on Centos x64 5.5
    and pre ispconfig binary install, I was getting all daemons up and getting a IMAP Server Connection refused error when I tried logging in with my user - is there something I need to edit to get rid of this bad user name error that is killing httpd ?


    the error is

    Starting httpd: httpd: bad user name ispapps
    [FAILED]


    Thank you,
     
  2. falko

    falko Super Moderator

    Is ispapps used somewhere in your Apache configuration? Does that user exist in /etc/passwd?
     
  3. ssscud

    ssscud New Member

    I could not find ispapps user anywhere neither getmail or ispconfig as well - so I created these three users and httpd could start again, but webmail (squirrelmail) is broken now, phpmyadmin and ispconfig all have error messages that say I don't have the rights to / - when I test urls, I have done this part of the how-to three times all with the same ispapps bad user name thing. I think the ispconfig3 installer is broken.

    what are the requisites for ispconfig dedicated setup?
     
  4. stre

    stre New Member

    Same Problem

    Hi everybody!

    I' ve get the same problem, the user doesn't exist in /etc/passwd, has anybody found out what todo or is the only way to dumb the ispConfig installation?

    thx for answers!
     
  5. falko

    falko Super Moderator

    Which distribution do you use?
     
  6. stre

    stre New Member

    centos 5.5 x86_64

    centos 5.5 x86_64
     
  7. falko

    falko Super Moderator

    Seems to be a CentOS problem. I've added this to our bugtracker.
     
  8. till

    till Super Moderator

    On my centos testinstall the ispapps user got added automatically. If this failed on your system, then add it with:

    Code:
    groupadd ispapps
    useradd -g ispapps -d /var/www/apps ispapps
     
  9. Wizard of Wiring

    Wizard of Wiring New Member

    above post did not resolve problem:

    error message no longer says "httpd: bad user name ispapps"

    current error message is "httpd: bad user name ispconfig"

    on a side note, following the post above spit out:
    aseradd: warning: the home directory already exists.
    Not copying any file from skel directory into it.

    I can see what the problem is on my installation.
    $command = "useradd -g ispconfig -d $install_dir ispconfig";

    in order for this to work on my centos 5.5 install it would need to say
    /usr/sbin/useradd -g...

    in the howto i had to add /sbin/ in front of the chkconfig commands:
    /sbin/chkconfig...

    so now I am tracking down what $install_dir =
    to do the groupadd/useradd
    looks like = /usr/local/ispconfig

    that allowed me to start apache but current error is:
    [warn] NameVirtualHost *.80 has no VirtualHosts

    Default Apache page pulls up at
    http://myipaddress

    Error Message pulls up at
    http://myipaddress:8080

    Forbidden

    You don't have permission to access / on this server.
     
    Last edited: Oct 5, 2010
  10. till

    till Super Moderator

    Looks as if the ispconfig installer was run by a unpriveliged user so that ispconfig could not create any of its Linux system users. You should download ispconfig again as root user, unpack it and then run the update.php script which is in the install subfolder. Choose y when the installer asks you to reconfigure services.
     
  11. Wizard of Wiring

    Wizard of Wiring New Member

    I am logged in as an unprivileged user using su

    Does it matter if ISPConfig is executed logged in as root or with su?

    In any event I tried to run update.php and immediately after being prompted for root mysql password I get this:

    Possible problem with dumping the database. We will stop here. Please check the file existing_db.sql
     
  12. falko

    falko Super Moderator

    Try to log in directly as root.
     

Share This Page