httpd failes to start after upgrade to current stable

Discussion in 'Installation/Configuration' started by Cybodog, Jan 6, 2011.

  1. Cybodog

    Cybodog New Member

    service httpd start
    Starting httpd: Syntax error on line 47 of /etc/httpd/conf/sites-enabled/000-ispconfig.vhost:
    Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration

    vhost file:


    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################

    Listen 8080
    NameVirtualHost *:8080

    <VirtualHost _default_:8080>
    ServerAdmin [email protected]

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options Indexes FollowSymLinks MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    AddHandler fcgid-script .php
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>

    <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    php_value magic_quotes_gpc 0
    </Directory>
    </IfModule>

    # ErrorLog /var/log/apache2/error.log
    # CustomLog /var/log/apache2/access.log combined
    ServerSignature Off

    <IfModule mod_security2.c>
    SecRuleEngine Off
    </IfModule>

    # SSL Configuration
    SSLEngine On
    SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
    SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key

    </VirtualHost>

    <Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>
    --------------end--------------

    As you can see line 47 is SSLENGINE On

    I DID give ssl cert a password during the upgrade to current stable.

    I don't know enough about how ISPConfig works yet to be able to fathom this out. I just installed it yesterday (Centos 5.5 following "perfect server").

    I also don't mind if I just wipe and to it again.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig config file is ok, it worked before the update because you had not tried to use ssl in a website yet and ssl is not available in your apache. Seems as if mod_ssl is not installed on your server. Please run:

    yum install mod_ssl

    and then

    /etc/init.d/httpd restart
     
  3. Cybodog

    Cybodog New Member

    Yup, that was it. Thanks Till!
     

Share This Page