httpd crashes after installing ISPconfig3

Discussion in 'Installation/Configuration' started by soldier, Apr 12, 2011.

  1. soldier

    soldier New Member

    After installing ESP 3 httpd gives error
    [root@localhost install]# /etc/init.d/httpd restart
    Останавливается httpd: [ СБОЙ ]
    Запускается httpd: [Tue Apr 12 08:40:30 2011] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Tue Apr 12 08:40:30 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
    (13)Permission denied: make_sock: could not bind to address [::]:8081
    (13)Permission denied: make_sock: could not bind to address 0.0.0.0:8081
    no listening sockets available, shutting down
    Unable to open logs

    Please help in solving the problem!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you run already some other software on port 8081. Please check with the command:

    netstat -tap

    which software uses that port and stop it. Then you should be able to start apache again.
     
  3. soldier

    soldier New Member

    [root@localhost ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdomain:10025 *:* LISTEN 3118/master
    tcp 0 0 *:mysql *:* LISTEN 3025/mysqld
    tcp 0 0 localhost.local:dyna-access *:* LISTEN 2944/clamd
    tcp 0 0 *:sunrpc *:* LISTEN 2665/portmap
    tcp 0 0 *:ftp *:* LISTEN 3147/pure-ftpd (SER
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 2648/named
    tcp 0 0 *:ssh *:* LISTEN 2922/sshd
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2931/cupsd
    tcp 0 0 *:con *:* LISTEN 2697/rpc.statd
    tcp 0 0 *:smtp *:* LISTEN 3118/master
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2648/named
    tcp 0 0 192.168.127.129:38267 ie.freshrpms.net:http TIME_WAIT -
    tcp 0 0 192.168.127.129:38266 ie.freshrpms.net:http TIME_WAIT -
    tcp 0 0 192.168.127.129:32825 ftp.nara.wide.ad.jp:http TIME_WAIT -
    tcp 0 0 192.168.127.129:32824 ftp.nara.wide.ad.jp:http TIME_WAIT -
    tcp 0 0 192.168.127.129:60739 mirror.yandex.ru:http TIME_WAIT -
    tcp 0 0 192.168.127.129:60742 mirror.yandex.ru:http TIME_WAIT -
    tcp 0 0 192.168.127.129:41400 222.122.43.209:http TIME_WAIT -
    tcp 0 0 192.168.127.129:41399 222.122.43.209:http TIME_WAIT -
    tcp 0 0 192.168.127.129:41398 222.122.43.209:http TIME_WAIT -
    tcp 1 0 192.168.127.129:56687 rhlx01.hs-esslingen.de:http CLOSE_WAIT 3625/python
    tcp 0 0 192.168.127.129:56678 rhlx01.hs-esslingen.de:http TIME_WAIT -
    tcp 0 0 192.168.127.129:49048 211.62.252.36:http TIME_WAIT -
    tcp 0 0 192.168.127.129:49049 211.62.252.36:http TIME_WAIT -
    tcp 0 0 192.168.127.129:49046 211.62.252.36:http TIME_WAIT -
    tcp 0 0 192.168.127.129:50935 server88-208-217-170.l:http TIME_WAIT -
    tcp 0 0 192.168.127.129:43260 mandril.creatis.insa-l:http TIME_WAIT -
    tcp 0 0 192.168.127.129:56674 centos.servint.net:http TIME_WAIT -
    tcp 0 0 192.168.127.129:34517 s334-kt9-sel.cdn1.net:http TIME_WAIT -
    tcp 0 0 192.168.127.129:41300 221x247x219x6.ap221.ft:http TIME_WAIT -
    tcp 0 0 192.168.127.129:41302 221x247x219x6.ap221.ft:http TIME_WAIT -
    tcp 0 0 192.168.127.129:49506 psw32.psw.net:http TIME_WAIT -
    tcp 0 0 192.168.127.129:51492 centos-mirror.hostdime:http TIME_WAIT -
    tcp 0 0 192.168.127.129:35527 ftp.chg.ru:http TIME_WAIT -
    tcp 0 0 192.168.127.129:35522 ftp.chg.ru:http TIME_WAIT -
    tcp 0 0 192.168.127.129:60291 earth.corbina.net:http TIME_WAIT -
    tcp 0 0 192.168.127.129:60288 earth.corbina.net:http TIME_WAIT -
    tcp 0 0 192.168.127.129:60318 earth.corbina.net:http ESTABLISHED 3625/python
    tcp 0 0 192.168.127.129:60285 earth.corbina.net:http TIME_WAIT -
    tcp 0 0 *:ftp *:* LISTEN 3147/pure-ftpd (SER
    tcp 0 0 localhost6.localdoma:domain *:* LISTEN 2648/named
    tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 2648/named
    [root@localhost ~]#

    not software uses port 8081 ?!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    And you accepted the default port 8080 for ispconfig as you installed it? You can not use 8081 for ispconfig interface as this would cause a collision with the ispconfig apps vhost which runs on 8081 already.
     
  5. soldier

    soldier New Member

    Yes I spent the installation instructions and accept the default port of 8080.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a virtual server?
     
  7. soldier

    soldier New Member

    Yes, server work in base VMware
     
  8. soldier

    soldier New Member

    Shutdown SElinux, error change:
    (13)Permission denied: make_sock: could not bind to address [::]:8081
    (13)Permission denied: make_sock: could not bind to address 0.0.0.0:8081
    ----->
    (98)Permission denied: make_sock: could not bind to address [::]:8081
    (98)Permission denied: make_sock: could not bind to address 0.0.0.0:8081
     
  9. soldier

    soldier New Member

    please suggest any solution to the problem!
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    You can change the port 8081 in the file /etc/apache2/sites-enabled/000-apps.vhost to a port that is not in use on your server.
     
  11. soldier

    soldier New Member

    [root@localhost ~]# /etc/init.d/httpd restart
    Останавливается httpd: [ СБОЙ ]
    Запускается httpd: [Wed Apr 13 11:12:55 2011] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Wed Apr 13 11:12:55 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:81
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:81
    no listening sockets available, shutting down
    Unable to open logs
    [ СБОЙ ]
    [root@localhost ~]# /etc/init.d/httpd restart
    Останавливается httpd: [ СБОЙ ]
    Запускается httpd: [Wed Apr 13 11:14:45 2011] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Wed Apr 13 11:14:45 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:8082
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:8082
    no listening sockets available, shutting down
    Unable to open logs
    [ СБОЙ ]
    [root@localhost ~]# /etc/init.d/httpd restart
    Останавливается httpd: [ СБОЙ ]
    Запускается httpd: [Wed Apr 13 11:17:05 2011] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Wed Apr 13 11:17:05 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:82
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:82
    no listening sockets available, shutting down
    Unable to open logs
    [ СБОЙ ]
    [root@localhost ~]#

    which port you can still try?
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you disabled and uninstalled selinux and that you rebooted the server afterwards.
     
  13. soldier

    soldier New Member

    Re-install OS, disable firewall and SElinux, install ISP. ALL WORK!!!!:)
    THANKS!!!
     

Share This Page