HTTP2 Apache Debian 10 ISPConfig 3.1

Discussion in 'Installation/Configuration' started by Trimilur, Apr 28, 2020.

  1. Trimilur

    Trimilur New Member

    to activate HTTP2.0 on ISPConfig 3.1 (Debian 10) can i basically just follow this description?

    Dont do I have to take anything into account because of ispconfig? And the last question, when I do not activate SPDY/HTTP2 in ispconfig is there still http1 available?

  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    That looks about right, it's pretty simple; instructions have been posted in the forums here in the past. I'd also uninstall mod_php since you're not using it.
    Not much. It's probably easier to set Protocols in a separate conf file, eg. create
    /etc/apache2/conf-available/http2.conf with:
    <IfModule mod_http2.c>
        Protocols h2 h2c http/1.1
    Then run a2enconf http2.
    I may not understand your question, but yes, it uses http1 by default, if you don't enable http2, that's what you're using.
    Trimilur likes this.
  3. Trimilur

    Trimilur New Member

    Ok thank you!,
    I followed the posted instructions as it was and just enabled SPDY/Https2 in the ispconfig Server config. And it already looks like it works.
    I also got the follwing http2.conf file as default

    <IfModule !mpm_prefork>
        Protocols h2 h2c http/1.1
        # # HTTP/2 push configuration
        # H2Push          on
        # # Default Priority Rule
        # H2PushPriority * After 16
        # # More complex ruleset:
        # H2PushPriority  *                       after
        # H2PushPriority  text/css                before
        # H2PushPriority  image/jpeg              after   32
        # H2PushPriority  image/png               after   32
        # H2PushPriority  application/javascript  interleaved
        # # Configure some stylesheet and script to be pushed by the webserver
        # <FilesMatch "\.html$">
        #     Header add Link "</style.css>; rel=preload; as=style"
        #     Header add Link "</script.js>; rel=preload; as=script"
        # </FilesMatch>
        # Since mod_http2 doesn't support the mod_logio module (which provide the %O format),
        # you may want to change your LogFormat directive as follow:
        # LogFormat "%v:%p %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
        # LogFormat "%h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined
        # LogFormat "%h %l %u %t \"%r\" %>s %B" common
    When i check my vhost config though after activating http2 i find this

     Protocols h2 http/1.1
                    SSLProtocol All -SSLv2 -SSLv3
    looks like i am missing this h2c is this a problem?

    Update: I read a little bit about it, looks like h2c is just the non ssl version of http2 so its actually fine only to have h2 on a ssl site
    Last edited: Apr 28, 2020

Share This Page