Discussion in 'HOWTO-Related Questions' started by Boter, Dec 10, 2009.

  1. Boter

    Boter New Member

    I folowed on this link.

    And I have A problem. Even squirrelmail doesen't work properly:

    ERROR: Connection dropped by IMAP server.

    Dirs in /home/vmail are not created, so I get error when trying in e.g. thunderbird "canot chdir to..."

    syslog says this:

    Dec 10 03:53:52 snowflake pop3d: Connection, ip=[::ffff:]
    Dec 10 03:53:56 snowflake pop3d: chdir No such file or directory

    I'm pretty shure everything is set like it should - followed the how-to and change user/passes... Any idea?

    Actually I get mail if I send it to [email protected] (that's my mail i would like to set up), which should be send to local user "mitja". I was doing this how-to over and over again, and always the same. Any idea what I'm doing wrong?

    I set some other mail too ([email protected]), syslog says

    Dec 10 03:57:12 snowflake postfix/cleanup[6740]: 8DE5B25E6A8: message-id=<[email protected]>
    Dec 10 03:57:12 snowflake postfix/qmgr[5916]: 8DE5B25E6A8: from=<[email protected]>, size=1618, nrcpt=1 (queue active)
    Dec 10 03:57:12 snowflake postfix/smtpd[6756]: disconnect from localhost[]
    Dec 10 03:57:12 snowflake postfix/trivial-rewrite[6739]: warning: do not list domain in BOTH mydestination and virtual_mailbox_domains
    Dec 10 03:57:12 snowflake amavis[5245]: (05245-05) Passed CLEAN, [] [] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: HgKhB2emTipU, Hits: 0.001, size: 1204, queued_as: 8DE5B25E6A8, 18911 ms
    Dec 10 03:57:12 snowflake postfix/local[6757]: 8DE5B25E6A8: to=<[email protected]>, relay=local, delay=0.05, delays=0.03/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
    Dec 10 03:57:12 snowflake postfix/qmgr[5916]: 8DE5B25E6A8: removed
    Dec 10 03:57:12 snowflake postfix/smtp[6741]: 92F8625E699: to=<[email protected]>, relay=[]:10024, delay=19, delays=0.16/0.01/0/19, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=05245-05, from MTA([]:10025): 250 2.0.0 Ok: queued as 8DE5B25E6A8)
    Dec 10 03:57:12 snowflake postfix/qmgr[5916]: 92F8625E699: removed
    Dec 10 03:57:23 snowflake postfix/smtpd[6736]: disconnect from[]

    and ufcorse - no dirs in /home/vmail no nothing. but somehow i don't get undelivered mail report.
    Last edited: Dec 10, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Remove from the mydestination line in /etc/postfix/ and restart Postfix.
  3. Boter

    Boter New Member

    Dec 11 12:42:17 snowflake imapd-ssl: chdir Permission denied

    Previus error was that dirs cannot be created, so I created them manually. and added chmod o= and chowned to postfix:postfix

    But still no go:

    Dec 11 12:44:27 snowflake postfix/qmgr[4088]: 95B2925E6B5: removed
    Dec 11 12:44:27 snowflake postfix/virtual[4240]: warning: check_dir_size: cannot open directory: /home/vmail/
    Dec 11 12:44:27 snowflake postfix/virtual[4240]: warning: maildir access problem for UID/GID=5000/5000: create maildir file /home/vmail/ Permission denied
    Dec 11 12:44:27 snowflake postfix/virtual[4240]: warning: perhaps you need to create the maildirs in advance
    Dec 11 12:44:27 snowflake postfix/virtual[4240]: B97A325E6B4: to=<[email protected]>, relay=virtual, delay=0.06, delays=0.02/0.02/0/0.02, dsn=4.2.0, status=deferred (maildir delivery failed: create maildir file /home/vmail/ Permission denied)
  4. reggiedarden

    reggiedarden New Member

    The vmail directories need to be owned by vmail.vmail
  5. Boter

    Boter New Member

    Dec 11 23:50:47 snowflake postfix/pickup[11113]: 2B6C525E6B6: uid=0 from=<root>
    Dec 11 23:50:47 snowflake postfix/cleanup[11120]: 2B6C525E6B6: message-id=<[email protected]>
    Dec 11 23:50:47 snowflake postfix/qmgr[11114]: 2B6C525E6B6: from=<[email protected]>, size=267, nrcpt=1 (queue active)

    Ok so now mail is sent. Now things should work... But it would be too damn good. Squirrelmail shows blank page after login.
  6. Boter

    Boter New Member

    Oh anyhow, forwards now works. Only squirrelmail has problems
  7. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that you introduced no PHP syntax error when you modified the config.php file of the change_sqlpass plugin.

Share This Page