http://www.domain.com/ shows login.php instead of index file

Discussion in 'Installation/Configuration' started by mtoom, Feb 27, 2007.

  1. mtoom

    mtoom New Member

    Why do my hosted domains redirect automatically to:

    http://www.domain.com/login.php

    Instead of displaying their default index.html files that are intact?!?

    Does anyone know why this is happening? :(
     
  2. mtoom

    mtoom New Member

    this is very very frustrating... i am very busy this week and i have wasted many hours on this software...

    i installed on a clean boot of CentOS & followed the "perfect setup" instructions exactly but the system does not work...

    why do my domains not show the files in their FTP directories? instead they just ask the user to login!?!! :mad:
     
  3. till

    till Super Moderator

    ISPConfig has no login.php files in the websites. So thats a problem which is not ISPConfig related.

    You should have a look if there is a .htaccess file in the directory that does some kind of redirect or if your index.html file contains a redirect.
     
  4. mtoom

    mtoom New Member

    It definitely is related!!

    Everything appears to be set up properly in the .conf files...

    However, it redirects to:

    /home/admispconfig/ispconfig/web/login.php

    I edited the title in the login.php like this:

    And changed the title line:

    Here is the hosting directory:

     
    Last edited: Feb 27, 2007
  5. mtoom

    mtoom New Member

    I think somehow, the server is set up to have login on BOTH http at port 80 and https at port 81... is that possible? Right now I only have one domain directed to this server...

    If I manually start httpd, after shutting off ispconfig, the hosting account behaves differently and I can view index.html

    I have no idea why.
     
  6. till

    till Super Moderator

    I guess you mix up websites and the ISPConfig controlpanel.

    If you connect to your server on port 80 it can not redirect to /home/admispconfig/ispconfig/web/login/trylogin.php because that server is listening on port 81. Check your router if you forward port 80 to 81 accidently!
     
  7. mtoom

    mtoom New Member

    I can log in and use the ispconfig control panel for either my http or https...


    HOWEVER

    If I do this:

    NOW:

    the http hosting works properly, but https

    Does NOT respond.
     
    Last edited: Feb 27, 2007
  8. mtoom

    mtoom New Member

    Now, once again, http gives the same result as: https:81

    You think that is a port forwarding issue? I was pretty sure it was related to ISPconfig http.conf settings somehow...?
     
    Last edited: Feb 27, 2007
  9. mtoom

    mtoom New Member

    There is no .htaccess

    The installation is on a virgin CentOS system & I have not added a .htaccess file to the dir.

    There is NO redirect... the index.html is exactly as created by ISPconfig:

     
    Last edited: Feb 27, 2007
  10. mtoom

    mtoom New Member

    AHHHH!!!!!!!!!!

    [​IMG]
     
  11. mtoom

    mtoom New Member

    its not a port forwarding issue...

    it's an ISPconfig configuration issue.
     
  12. till

    till Super Moderator

    The ISPConfig httpd never listens on port 80 if you did not cahnge the ports in the file /root/ispconfig/httpd/conf/httpd.conf manually.

    Please start your normal webserver and the the ispconfig_server and then post the output of: netstat -tap
     
  13. mtoom

    mtoom New Member

    okay here you go

    netstap tap
     
  14. mtoom

    mtoom New Member

    i dont know if it is running on port 80 or not... what i mean is, maybe control panel is set up for both http & https by accident!
     
  15. till

    till Super Moderator

    Your ISPConfig httpd is listening on port 80 too which is not possible without manually changing the httpd.conf file that I mentioned above.

    Did you do any manual changes to this file? If yes, undo them.
     
  16. mtoom

    mtoom New Member

    If I remove these lines and reboot, then http://www.domain.com/ goes dead...


    netstat -tap after removing the lines & restarting ispconfig...
     
    Last edited: Feb 27, 2007
  17. mtoom

    mtoom New Member

    no still not working ...
     
    Last edited: Feb 27, 2007
  18. mtoom

    mtoom New Member

    i thought it was fixed but no...

    www.domain.com gives a dead link when i removed those lines
     
    Last edited: Feb 27, 2007
  19. mtoom

    mtoom New Member

    Doing this appears to make everything work... but only if I type "httpd -k start" ... Just starting the ISP config server doesn't make the httpd work...

    Is that normal?
     
  20. mtoom

    mtoom New Member

    thank you very very much for all your help Till

    the reason I am so crazy about getting this working... is because in 36 hours my old server goes offline (if I want to keep it longer, I have to pay $99 US)... and I must transfer all client websites and switch DNS within 36 hours or I lose $100 :(
     

Share This Page