http and smtp error

Discussion in 'Installation/Configuration' started by ariban99, May 2, 2016.

  1. ariban99

    ariban99 Member

    Hi,
    I installed ispconfig3 just now and when i go to mxtoolbox.com and run a domain health test, everything is fine besides these 3 errors
    3 Problems
    Category Host Result
    [​IMG] smtp mail.mydealsexpress.com Failed To Connect [​IMG] More Info
    [​IMG] http mydealsexpress.com Unable to connect to the remote server (http://mydealsexpress.com) [​IMG] More Info
    [​IMG] smtp mail.mydealsexpress.com Failed To Connect [​IMG] More Info

    I disabled firewalld, i can view my site from the internal local lan ip.
    no firewalls are blocking anything, my router pfsense has all the ports open.
    i tried everything and dont know what do to. can anyone help please.
    USING APACHE2 on centos 7 with ispconfig3

    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:10024 0.0.0.0:* LISTEN 5761/amavisd (maste
    tcp 0 0 localhost:cslistener 0.0.0.0:* LISTEN 1331/php-fpm: maste
    tcp 0 0 localhost:10025 0.0.0.0:* LISTEN 4285/master
    tcp 0 0 localhost:10026 0.0.0.0:* LISTEN 5761/amavisd (maste
    tcp 0 0 0.0.0.0:mysql 0.0.0.0:* LISTEN 4464/mysqld
    tcp 0 0 localhost:10027 0.0.0.0:* LISTEN 4285/master
    tcp 0 0 0.0.0.0:pop3 0.0.0.0:* LISTEN 1368/dovecot
    tcp 0 0 0.0.0.0:imap 0.0.0.0:* LISTEN 1368/dovecot
    tcp 0 0 0.0.0.0:ftp 0.0.0.0:* LISTEN 3784/pure-ftpd (SER
    tcp 0 0 webserver1.mydea:domain 0.0.0.0:* LISTEN 1922/named
    tcp 0 0 localhost:domain 0.0.0.0:* LISTEN 1922/named
    tcp 0 0 0.0.0.0:ssh 0.0.0.0:* LISTEN 1336/sshd
    tcp 0 0 0.0.0.0:smtp 0.0.0.0:* LISTEN 4285/master
    tcp 0 0 localhost:rndc 0.0.0.0:* LISTEN 1922/named
    tcp 0 0 0.0.0.0:imaps 0.0.0.0:* LISTEN 1368/dovecot
    tcp 0 0 0.0.0.0:pop3s 0.0.0.0:* LISTEN 1368/dovecot
    tcp 66 0 localhost:56046 localhost:10025 CLOSE_WAIT 7627/amavisd (ch1-a
    tcp 0 0 webserver1.mydealse:ssh 192.168.1.15:60794 ESTABLISHED 11322/sshd: [email protected]
    tcp 66 0 localhost:56052 localhost:10025 CLOSE_WAIT 7623/amavisd (ch1-a
    tcp 0 336 webserver1.mydealse:ssh 192.168.1.15:60529 ESTABLISHED 4581/sshd: [email protected]
    tcp6 0 0 localhost:10024 [::]:* LISTEN 5761/amavisd (maste
    tcp6 0 0 localhost:10026 [::]:* LISTEN 5761/amavisd (maste
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 1368/dovecot
    tcp6 0 0 [::]:imap [::]:* LISTEN 1368/dovecot
    tcp6 0 0 [::]:webcache [::]:* LISTEN 3854/httpd
    tcp6 0 0 [::]:http [::]:* LISTEN 3854/httpd
    tcp6 0 0 [::]:tproxy [::]:* LISTEN 3854/httpd
    tcp6 0 0 [::]:ftp [::]:* LISTEN 3784/pure-ftpd (SER
    tcp6 0 0 [::]:domain [::]:* LISTEN 1922/named
    tcp6 0 0 [::]:ssh [::]:* LISTEN 1336/sshd
    tcp6 0 0 [::]:smtp [::]:* LISTEN 4285/master
    tcp6 0 0 localhost:rndc [::]:* LISTEN 1922/named
    tcp6 0 0 [::]:https [::]:* LISTEN 3854/httpd
    tcp6 0 0 [::]:imaps [::]:* LISTEN 1368/dovecot
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 1368/dovecot

    thank you
    Ben
     
  2. Jesse Norell

    Jesse Norell Active Member

    I can't connect from here either. If you have firewalld disabled, see what your firewall rules look like (iptables -L -n -v) - ideally you would have INPUT/FORWARD/OUTPUT with ACCEPT policy, and no other chains defined.

    Do you have a public address right on your ispconfig server, or also using NAT? If the latter, check your port forwards and firewall rules in pfsense. Check firewall logs there, and see if the HTTP (port 80) or SMTP (port 25) requests are being blocked.
     
  3. ariban99

    ariban99 Member

    iptables -L -n -v
    Chain INPUT (policy ACCEPT 1674 packets, 339K bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 1736 packets, 815K bytes)
    pkts bytes target prot opt in out source destination
     
  4. ariban99

    ariban99 Member

    ok i figured it out after 3 days!! lol
    my comcast business modem had port management turned on and it was blocked incoming ports. i turned that off. even though i put it in virtual bridge mode so it only uses my pfsense, somehow comcast was causing issues!!
    finally!! its amazing ispconfig 3 it works great!!
     

Share This Page