HTTP 500 After Upgrade OS

Discussion in 'Installation/Configuration' started by demby, Jan 12, 2017.

  1. demby

    demby New Member

    hi, i just upgraded my ubuntu 14.04 to 16.04. I also install php5.6 and php7.0. So, i can switch php version.
    And mysql version is 5.7. I have created phpinfo.php, accessed it and i can see mysqli was enabled.

    The problem is I cannot access my ispconf dashboard or client site. All i've got is only http error 500.
    This is the error i got from apache log :
    [fcgid:warn] [pid 27493] [client xxxxx] mod_fcgid: stderr: PHP Fatal error: Class 'mysqli' not found in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 31

    I had set mysql password of dbispconfig same as password on /usr/local/ispconfig/interface/lib/config.inc.php
    I also had update ispconfig using ispconfig_updates.sh and from ispconfig install using php -q update.php
    It didnot work either.

    Any idea what should i do now?

    FYI, i can access phpmyadmin using hxxs://domain:8080/phpmyadmin
    Code:
    $php -m
    [PHP Modules]
    calendar
    Core
    ctype
    date
    ereg
    exif
    fileinfo
    filter
    ftp
    gettext
    hash
    iconv
    json
    libxml
    mbstring
    mhash
    mysql
    mysqli
    mysqlnd
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    Phar
    posix
    readline
    Reflection
    session
    shmop
    sockets
    SPL
    standard
    sysvmsg
    sysvsem
    sysvshm
    tokenizer
    xdebug
    Zend OPcache
    zlib
    
    [Zend Modules]
    Xdebug
    Zend OPcache
    
    Code:
    $php -v
    PHP 5.6.29-1+deb.sury.org~xenial+1 (cli)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
        with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
        with Xdebug v2.5.0, Copyright (c) 2002-2016, by Derick Rethans
    
    Code:
    $php -v
    $php -r 'phpinfo();' | grep -i mysqli
    /etc/php/5.6/cli/conf.d/20-mysqli.ini,
    mysqli
    MysqlI Support => enabled
    mysqli.allow_local_infile => On => On
    mysqli.allow_persistent => On => On
    mysqli.default_host => no value => no value
    mysqli.default_port => 3306 => 3306
    mysqli.default_pw => no value => no value
    mysqli.default_socket => no value => no value
    mysqli.default_user => no value => no value
    mysqli.max_links => Unlimited => Unlimited
    mysqli.max_persistent => Unlimited => Unlimited
    mysqli.reconnect => Off => Off
    mysqli.rollback_on_cached_plink => Off => Off
    API Extensions => mysql,mysqli,pdo_mysql
    
     
  2. sjau

    sjau Local Meanie Moderator

    did you reconfigure the services?
     
  3. Jesse Norell

    Jesse Norell Well-Known Member

    You're missing the package for mysql support in php (looks to be 'php7.0-mysql'). Go through the Perfect Server guide for Ubuntu 16.04 and make sure you have installed all the required packages/software, and to be safe you might re-run an ispconfig update and reconfigure services.
    https://www.howtoforge.com/tutorial...l-pureftpd-bind-postfix-doveot-and-ispconfig/
     
  4. demby

    demby New Member

    No, I didnot.
     
  5. demby

    demby New Member

    Now, it run and i can access the dashborad and client site.
    It fixed by removed all php7.* packages and only use php5.6.
    Code:
    sudo apt purge php7.*
    
    Another problem is pureftpd is not running. Any idea ?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Restart t and then check the syslog file for errors and use the systemd command that the restart failure suggests to get details about the reason why it does not start.
     
  7. alisik

    alisik Banned

    why restart?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    When a daemon is not started, and you restart it, then you will see the errors why this daemon does not start in the log or systemd output.
     
  9. demby

    demby New Member

    Thank you till. I have restart and it still failed. So, i tried to find the pureftp using find / -name pureftpd but nothing found.
    So i reinstall pureftpd and now it fixed.
    Thank you everyone. :)
     
    till likes this.

Share This Page