http 2

Discussion in 'Installation/Configuration' started by Lodivod, Mar 21, 2019.

  1. Lodivod

    Lodivod Member

    Hi, I'm trying http 2 on a server with Ubuntu 18.04 and ISPConfig 3.1.
    Apache version: Apache/2.4.29 (Ubuntu)
    I followed the instructions here but not work. I tried PHP 7.2 mod_php and PHP 5.6 PHP-FPM. In vhost config is correctly set to
    Protocols h2 http/1.1
    Can anyone help?
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    In what way does it not work?
  3. Lodivod

    Lodivod Member

  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  5. Lodivod

    Lodivod Member

    the instructions are:
    a2dismod php7.2
    a2dismod mpm_prefork
    a2enmod mpm_event
    service apache2 restart

    but we have a production server running 200 domains. 90% domains used mod_php 7.2
    when I disable php7.2 by a2dismod php7.2 will sites work?
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    That depends on what PHP version they are set to. Hopefully you are mistaken and the sites do not run in mod_php mode, but fpm or fastcgi. If they are set to a php version added via System > Additional PHP Versions you should be fine, as you can't even use mod_php there. If they are not, I would first add a PHP version there and switch sites to it (you may have to change file/directory ownership if you indeed were running mod_php) .. it is some work to do, but you can take heart knowing you are improving the security of every single website and your server overall. :) And you should be able to script it once you do one or two and note the changes required.

    After all sites are off mod_php, I would try:
    a2dismod php7.2
    a2enconf php7.2-fpm
    service apache2 restart
    And ensure ISPConfig still works. Then you can switch the php worker module and start using http2.
  7. Lodivod

    Lodivod Member

    Thanks, I'll test it.

Share This Page