HTTP/2 phpmyadmin / webmail ?

Discussion in 'Installation/Configuration' started by jonathannet, Dec 30, 2018.

  1. jonathannet

    jonathannet Member

    Hi ISPConfig

    I am running with ISPConfig and enabled the HTTP/2 protocol, all the sites works, but not if I type domain.dk/phpmyadmin or domain.dk/webmail

    I only get the php in text there, how do I fix that so it also works on those domains?
     
  2. ahrasis

    ahrasis Well-Known Member

    In nginx you can try adding http2 at the end of listen line but I think you are using apache2. So if your apache2 already compiled with and/or enabled mod_http2, try adding h2 in its protocols line.
     
  3. jonathannet

    jonathannet Member

    Hi ahrasis, I dont use ngnix only apache2 as webserver :)
     
  4. ahrasis

    ahrasis Well-Known Member

    That's the attitude of most users everywhere, expecting proper help without providing proper details. Thanks?
     
  5. jonathannet

    jonathannet Member

    What do you mean by my attitude, yeah sorry for not posting that is used Apache2 as webserver, but thanks for helping anyways :D
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    phpmyadmin and webmail package from Debian and Ubuntu are using mod_php by default, but HTTP/2 is not compatible with the prefork MPM which is required by mod_php, so these default apps don't have a PHP interpreter anymore after your change to HTTP/2. You will have to manually configure PHP for them e.g. trough PHP FPM.
     
    ahrasis and jonathannet like this.
  7. jonathannet

    jonathannet Member

    Okay thanks, I just created some subdomains for phpmyadmin and webmail, and deleted the 2 conf files from /etc/apache2 :) works fine now :)
     

Share This Page