.htacess in stats folder problem

Discussion in 'Installation/Configuration' started by pendexgabo, Feb 19, 2007.

  1. pendexgabo

    pendexgabo New Member

    hi.
    I have a problem with one of two my ispconfig.

    a have 2 IPs with ispconfig
    the first control panel is version 2.2.6... when a try login in /stats folder its works fine for all sites in that IP.

    the other control panel has a version 2.2.7 but when I try login in /stats folder not work.
    i saw in error.log for one of the sites and the message is :
    require directives present and no Authoritative handler

    also I can saw a lot of modules enabled for the second apache
    like:
    auth_basic
    authn_file
    authz_default
    authz_gropufile
    authz_host

    i tried disable that modules, but I restart the httpd, give me error..


    the first control panel run fine over apache without this modules. I not know why..

    somebody can helpme ??
    sorry for my english..

    tanks for all
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What are the exact error messages?

    Which distribution do you use?
     
  3. pendexgabo

    pendexgabo New Member

    Code:
    kipux:~# a2dismod authz_groupfile
    Module authz_groupfile disabled; run /etc/init.d/apache2 force-reload to fully disable.
    kipux:~# /etc/init.d/apache2 restart
    Forcing reload of web server (apache2)....
    kipux:~# a2dismod authz_host
    Module authz_host disabled; run /etc/init.d/apache2 force-reload to fully disable.
    kipux:~# /etc/init.d/apache2 restart
    Forcing reload of web server (apache2)...Syntax error on line 6 of /etc/apache2/conf.d/apache2-doc:
    Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration
     failed!
    
    I use Debian Sarge with testing repositories. With Mysql5, PHP5, apache2


    this is a recent error when disable authz_groupfile
    Code:
    [Tue Feb 20 13:12:33 2007] [error] access to /stats/ failed, reason: require directives present and no Authoritative handler.
    tanks again
     
    Last edited: Feb 20, 2007
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please enable the mod_access module:
    Code:
    a2enmod access
    Then restart Apache.
     
  5. pendexgabo

    pendexgabo New Member

    falko

    i don't have this module avaiable..
    i tried with mod_access from apache1.3 ( apache2 docs say modules are compatible but not work)

    this are my steps

    Code:
    kipux:~# a2enmod access
    This module does not exist!
    kipux:~# a2enmod mod_access
    This module does not exist!
    
    kipux:/usr/lib/apache2/modules# locate mod_access
    /root/ispconfig/httpd/htdocs/manual/mod/mod_access.html.en
    /root/ispconfig/httpd/htdocs/manual/mod/mod_access.html.html
    /root/ispconfig/httpd/htdocs/manual/mod/mod_access.html.ja.jis
    /usr/lib/apache/1.3/210mod_access.info
    /usr/lib/apache/1.3/mod_access.so
    
    (in this part i copy mod_access to apache2)
    
    kipux:/usr/lib/apache2/modules# a2enmod mod_access
    Module mod_access installed; run /etc/init.d/apache2 force-reload to enable.
    kipux:/usr/lib/apache2/modules# /etc/init.d/apache2 restart
    Forcing reload of web server (apache2)...apache2: Syntax error on line 116 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/mod_access.load: Cannot load /usr/lib/apache2/modules/mod_access_13.so into server: /usr/lib/apache2/modules/mod_access_13.so: undefined symbol: ap_table_get
     failed!
    kipux:/usr/lib/apache2/modules# a2dismod mod_access
    Module mod_access disabled; run /etc/init.d/apache2 force-reload to fully disable.
    kipux:/usr/lib/apache2/modules# /etc/init.d/apache2 restart
    Forcing reload of web server (apache2)...httpd (no pid file) not running
    
    you know where I can download/how install this module for apache2

    one more time... sorry for my english.. and tanks for you patience
     
  6. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    Compatible here means compatible syntax for the user. You cannot mix 1.3 binaries with 2.x binaries. Please install only one webserver (remove 1.3?). You seem to have a mixed setup, which makes it very difficult to debug/ help you. :(
     

Share This Page