Discussion in 'General' started by erik, Sep 27, 2006.

  1. erik

    erik New Member

    After upgrading to 2.2.6 (fedora core 4) I've experienced some problems.

    I'm unable to protect files/directories through web-ftp (if I do this i get the following error: Failed to open /home/admispconfig/ispconfig/temp/hta_35QuJp), php.ini isn't incuded anymore (i've copied php.ini to php.d and now it is included) and set_ini() isn't working.

    Has someone simular problems and more important does some know how to solve these problems?

  2. falko

    falko Super Moderator ISPConfig Developer

    I've never had such a problem...
    Is SELinux disabled on your system?
  3. erik

    erik New Member

    Yep, SELinux is disabled.
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -la /root/ispconfig/php
    ? Are there any errors in /root/ispconfig/httpd/logs/error_log?
  5. erik

    erik New Member

    the out come of ls -la /root/ispconfig/php is
    I have a lot of errors from /root/ispconfig/httpd/logs/error_log but I think these are relevant
    The rest of the errors are phpmyadmin related
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you changed anything manually in the php.ini file in /root/ispconfig/php/php.ini e.g. enabling safemode?
  7. erik

    erik New Member

    safemode is disabled for /root/ispconfig/php/php.ini and /etc/php.d/php.ini, and there are no changes made in /root/ispconfig/php/php.ini

    The funny thing is that I can protect folders in some other websites.

    PS. I forgot to mention the following, when I updated tho version 2.2.6 the diskspace ran out and the installation was aborted. ISPConfig was completly unusable. I cleaned up my disk and reinstalled ISPConfig again.
  8. erik

    erik New Member

    Okay, I solved one problem. In the folder was a .htpasswd file present. when I removed this file I could reset the username and password through web-ftp.

    Now the set_init() (for site created with ISPConfig) issue... I have absolutly no idea where to start with this problem.
  9. falko

    falko Super Moderator ISPConfig Developer

    Where exactly are you using this function? In a web site run by the main Apache? Anything in Apache's error log? What does the disable_functions line look like in your php.ini?
  10. erik

    erik New Member

    I'm using the function in the main Apache on ISPConfig created domains.

    disable_functions is undefined ('disable_functions =') in the php.ini

    The output of /etc/httpd/logs/error_log is numerous of the following error/notice
  11. falko

    falko Super Moderator ISPConfig Developer

  12. erik

    erik New Member

    Okay... solved the problem with the error_log too :D!

    The problem with ini_set() was no problem at all. I just didn't test the right things (I'm such a rookie).

    Thanks for all you're help Falko!!!!
    Last edited: Oct 5, 2006

Share This Page