Discussion in 'Tips/Tricks/Mods' started by andrei, Apr 18, 2007.

  1. andrei

    andrei New Member

    Hey there.I'm new with ispconfig.I've created few domains for testing ..and i got an website wich need .htaccess to work.The .htaccess file looks like this:

    php_flag register_globals On

    RewriteEngine On
    #RewriteBase /

    RewriteRule ^links/(.*)_([0-9]+)_l$ links/index.php?category=$1&page=$2 [NC]
    RewriteRule ^links/(.*)_l$ links/index.php?category=$1 [NC]

    RewriteRule ^all_models_([0-9]+) all_models.php?page=$1 [NC]
    RewriteRule ^s_(.*) search_models.php?word=$1 [NC]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^([A-Za-z0-9_]+) model_profile.php?user=$1 [L]

    But when i add it into web1/web ,my page goes to 500 error.Have any ideea please ?
  2. bschultz

    bschultz Member

    you need to enable .htaccess in either in the website details of the ISPConfig admin panel, or by hand in the "vhosts" section of the Apache config.

    Something like this should work for you:

    <Directory "/var/www/web1/web/">
    	Options FollowSymLinks
    	AllowOverride All

Share This Page