.htaccess problem on Ubuntu 7.04 server

Discussion in 'HOWTO-Related Questions' started by dağcı, Sep 23, 2007.

  1. dağcı

    dağcı New Member

    Hey all this is my second message and my first message on how to questions so im sorry if im asking at wrong place :(

    Problem: I cant use .htaccess files. I get "Cant find the page error."

    What did i do?: Installed Ubuntu Server [7.04] with this guide , enabled rewrite mode with "a2enmod rewrite"

    Any other problems?: No
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in Apache's error log?
     
  3. dağcı

    dağcı New Member

    No errors but when i add a virtual host via webmin and change one line

    Options +Includes +FollowSymlinks -Indexes

    like this, problems gone and i can use htaccess but in my default virtual hosts file i couldnt do that. here is my default virtual host file.

    Code:
    NameVirtualHost *
    <VirtualHost *>
    	ServerAdmin [email protected]
    	
    	DocumentRoot /home/yalcin/my/geldik/
    	<Directory />
    		Options +Includes +FollowSymlinks -Indexes
    		AllowOverride None
    	</Directory>
    	<Directory /home/yalcin/my/geldik/>
    		Options +Includes +FollowSymlinks -Indexes
    		AllowOverride None
    		Order allow,deny
    		allow from all
    		# This directive allows us to have apache2's default start page
                    # in /apache2-default/, but still have / go to the right place
                    #RedirectMatch ^/$ /apache2-default/
    	</Directory>
    
    	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    	<Directory "/usr/lib/cgi-bin">
    		AllowOverride None
    		Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    		Order allow,deny
    		Allow from all
    	</Directory>
    
    	ErrorLog /var/log/apache2/error.log
    
    	# Possible values include: debug, info, notice, warn, error, crit,
    	# alert, emerg.
    	LogLevel warn
    
    	CustomLog /var/log/apache2/access.log combined
    	ServerSignature On
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>
    
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Why can't you do that in your default virtual hosts file?
     
  5. dağcı

    dağcı New Member

    i did as shown on my default configuration file but its not working :(
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Is the default vhost handling the web site where you have the problem? I.e., did you add the configuration to the correct vhost?
     
  7. dağcı

    dağcı New Member

    i solved the problem this is my new configuration file ;)

    Code:
    NameVirtualHost *
    <VirtualHost *>
    	ServerAdmin [email protected]
    	
    	DocumentRoot /home/yalcin/my/geldik/
    	<Directory />
    		Options FollowSymLinks
    AllowOverride None
    	</Directory>
    	<Directory /home/yalcin/my/geldik/>
    		Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    		# This directive allows us to have apache2's default start page
                    # in /apache2-default/, but still have / go to the right place
                    #RedirectMatch ^/$ /apache2-default/
    	</Directory>
    
    	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    	<Directory "/usr/lib/cgi-bin">
    		AllowOverride None
    		Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    		Order allow,deny
    		Allow from all
    	</Directory>
    
    	ErrorLog /var/log/apache2/error.log
    
    	# Possible values include: debug, info, notice, warn, error, crit,
    	# alert, emerg.
    	LogLevel warn
    
    	CustomLog /var/log/apache2/access.log combined
    	ServerSignature On
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>
     

Share This Page