.htaccess not visible from ftp

Discussion in 'Installation/Configuration' started by gkovacs, Apr 28, 2009.

  1. gkovacs

    gkovacs New Member

    If I upload a .htaccess file via FTP, it becomes invisible as soon as I refresh.
    (This is a newly created, empty site and new ftp user to avoid any problems.)

    I can see the file from the shell fine:
    Code:
    root@ispconfig:/var/clients/client4/web40/web# ls -la
    total 36
    drwxr-xr-x 4 web40 client4 4096 Apr 28 16:44 .
    drwxr-xr-x 6 root  root    4096 Apr 28 16:18 ..
    -rw-r--r-- 1 web40 client4    9 Apr 28 16:35 .htaccess
    -rw-r--r-- 1 web40 client4    9 Apr 28 16:44 a.htaccess
    drwxr-xr-x 2 web40 client4 4096 Apr 28 16:18 error
    -rwxr-xr-- 1 web40 client4 1406 Apr 28 16:18 favicon.ico
    -rwxr-xr-- 1 web40 client4 1861 Apr 28 16:18 index.html
    -rwxr-xr-- 1 web40 client4   34 Apr 28 16:18 robots.txt
    drwxr-xr-x 2 root  root    4096 Apr 28 16:18 stats
    
    From this list, a.htaccess is visible from FTP, while .htaccess is not:
    [​IMG]

    What gives?
     
    Last edited: Apr 28, 2009
  2. SirLancelot

    SirLancelot New Member

  3. gkovacs

    gkovacs New Member

    Thanks for the idea, but the problem is NOT CAUSED BY the DisplayDotFiles config directive of Pure-FTPD.

    I have a site where I can see .htaccess files from FTP, while on another one I cannot, regardless of DisplayDotFiles setting. Any other idea?
     
  4. SirLancelot

    SirLancelot New Member

    I'm not sure if I am reading your issue correctly but from you screen captures and description it looks as though you can see "a.htaccess" but not ".htaccess" of course you will see "a.htaccess" because it does not begin with a "."
     
  5. gkovacs

    gkovacs New Member

    You might want to read what I wrote again.
     
  6. SirLancelot

    SirLancelot New Member

    What ftp client are you using?
    Is there an option in your ftp client to show/hide hidden files?
    Have you tried any other ftp clients?
    This may be distribution related, what Linux Distro is your server using?
    From your first post there is no indication if you have enabled the DisplayDotFiles config directive.
     
  7. tebokkel

    tebokkel New Member

    Perhaps an explicit filter on .htaccess filenames in PureFTPd?

    Or perhaps a custom setting on the FTP-client? Does a local (commandline) FTP show or hide the .htaccess?

    Paul
     
  8. ggarcia24

    ggarcia24 New Member

    I know that Filezilla (that's what it looks to me) have an option to "not list" hiddend files, I'm remembering it right now but as soon as I get home i'll post where is it ;-)
     

Share This Page