htaccess error 500 Mandriva ISPConfig

Discussion in 'Server Operation' started by gaspiman, Nov 15, 2006.

  1. gaspiman

    gaspiman New Member

    Hi to all,
    This is my first post and i want to day that HowToForge rules! Great work guys.

    Ok here is my problem Btw I have read everything in the forum and done what's necessary - but still the problem persist.

    I have a small htaccess file that makes some Rewrite - AllowOveride All but still I receive a ERROR 500


    HTACCESS:

    Options +FollowSymlinks
    RewriteEngine on
    RewriteCond %{REQUEST_URI} !\.(css|gif|jpg|php|xml|pdf|js) [NC]
    RewriteRule ^([^/\.]+)/?$ index.php?id=$1 [NC]

    httpd.conf:
    <Directory /var/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride All
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    Apache error log:
    No errors

    Website error log:
    [Wed Nov 15 09:07:21 2006] [alert] [client 195.149.250.50] /var/www/web5/web/.htaccess: Options not allowed here

    Vhost conf:

    <VirtualHost 100.100.100.100:80>
    ServerName www.domain.tv:80
    ServerAdmin webmaster@domain.tv
    DocumentRoot /var/www/web5/web
    ServerAlias domain.tv
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web5/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web5/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode Off
    AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
    AddType text/vnd.wap.wml .wml
    AddType text/vnd.wap.wmlscript .ws .wmlscript
    AddType image/vnd.wap.wbmp .wbmp
    Alias /error/ "/var/www/web5/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web5/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web5/user/$1/web/$3
    </VirtualHost>


    PS: I have restarted Apache several times ...

    Please help guys :) Thank you very much in advance
     
    Last edited: Nov 15, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Please remove the Options line from .htaccess or put it between <Directory ...></Directory>.

    Please change it to
    Code:
    <Directory /var/www/*/web>
        Options +Includes +FollowSymlinks -Indexes
        AllowOverride All
        [B][COLOR="Red"]#[/COLOR][/B]AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
     
  3. gaspiman

    gaspiman New Member

    Thank you !

    Thank you Falko - Everything's fine now.

    You're the best!
     
  4. oxxmoxx

    oxxmoxx New Member

    htaccess | error 500 | joomla

    hi,

    falko, thanks for your hint. So I have solve my problem :) .

    For all, who works with the internal SEO from joomla:

    .htaccess:
    # Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*) index.php

    httpd.conf (from Falko)
    <Directory /var/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride All
    #AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    -> apache restart -> and the internal Joomla SEO works fine ...

    Greetz
    Alex
     

Share This Page