.htaccess and php_flag register_globals on

Discussion in 'Installation/Configuration' started by edge, Mar 9, 2006.

  1. edge

    edge Active Member Moderator

    For some reason I keep getting a 500 error when I add php_flag register_globals on to the .htaccess file for sites running on my server. When I set register_globals to on in the php.ini file all is working fine!

    Is there a reason that I can not set php_flag register_globals on in the .htaccess for the sites needing this?
    (I do not really want to set register_globals on in the PHP.ini as this if for all the sites on the server)

    The php_flag register_globals on in the .htaccess works fine on my old server runing PHP4

    The new server is setup with the perfect_setup_fedora_core_4.
  2. bjmg

    bjmg New Member

    This is normal and correct.
    You can't set that option unless you allow it on your apache configuration. You have to change AllowOverride on the right place to "AllowOverride All". Anyway, you should not do that!
    Do it with the optional Apache directives in ISPConfig.

  3. edge

    edge Active Member Moderator

    Hi Bernhard,

    I've had a look for the 'optional Apache directives in ISPConfig', but can not find it.

    Is it within the ISPConfig (port 81) itself, or do I need to do a small 'code' hack?
  4. edge

    edge Active Member Moderator

    re: 'optional Apache directives in ISPConfig'
    Nevermind.. I found it..

    I created a 'Client' without the 'Apache directives' for myself.. Thats why I do not have it! :p

    Now I have to find a way of adding the 'Apache directives' without killing the account ... :(
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If you enable apache directives for the reseller, you will be able to insert the directive when you are logged in as admin or reseller.
  6. falko

    falko Super Moderator ISPConfig Developer

    Please put
    php_[B][COLOR="Red"]admin[/COLOR][/B]_flag register_globals on
    into the Apache Directives field instead of
    php_flag register_globals on
  7. edge

    edge Active Member Moderator

    Actually I needed to add:
    php_admin_flag register_globals on
    php_admin_flag register_long_arrays on
    in it to make it work (OSCommercer)

    Thank you all for the help

Share This Page