hpMyAdmin gives "file could not be read" error

Discussion in 'Installation/Configuration' started by Cracklefish, Dec 2, 2012.

  1. Cracklefish

    Cracklefish Member HowtoForge Supporter

    My server is Perfect Server - Suse 11.3 Tutorial, ISPC

    I get a "file could not be read" error when I try to import any .csv file (<2MB)into a any table.

    The machine is about 2 years old, has had no changes since being put into service apart from a HDD replacement. This function worked originally but has never been needed again, until now. I have not (yet?) encountered any other phpMyAdmin functions that fail but then this is not a busy system. Until now, all mySQL tweaks have been so trivial that an edit using pMA was all that was required.

    I have checked out many posts regarding this error but not found any cure.

    Any ideas anyone?
  2. falko

    falko Super Moderator ISPConfig Developer

    Maybe the format of the CSV file is not ok?
  3. Cracklefish

    Cracklefish Member HowtoForge Supporter

    Possibly but afaik I made it the same way as before by saving an excel spreadsheet as a .csv under xp. That failed. I opened and saved it with notepad - same result then tried with notepad++ - just the same.

    I tried with and without a blank line at the end of the list.
    I tried terminating the fields with a colon :))

    I tried using firefox and ie8 under xp still same result.

Share This Page