HowtoBuild & Configure: [TuT]The Perfect Server - Ubuntu 18.04 + WP + 3 Websites

Discussion in 'HOWTO-Related Questions' started by Newbie19, Nov 14, 2019.

  1. Newbie19

    Newbie19 New Member HowtoForge Supporter

    Hello forum world


    Me: Complete linux beginner

    Setup:
    KVM OpenStack 1 vCore(s) 2 GHz 2 Gb RAM 20 Gb SSD Local RAID
    Ubuntu 18.04

    Goal:
    Host & configure 3 WordPress websites, smtp server. Learn a lot. Contribute it back in the shape of a tutorial later.

    Start:
    Today used the auto-installer from https://www.howtoforge.com/community/threads/ispconfig-and-perfect-server-howto-autoinstaller.82563/
    using
    Code:
    curl https://get.ispconfig.org | sh -s -- --use-amavis --use-nginx --no-quota
    added the
    Code:
    --no-quota 
    because that's what the terminal told me to do...

    Next I used a [I think - visually/functionally it's amazing] great tutorial here [warning French] https://cxyz.fr/blog/2019-07/installer-wordpress-sur-un-vps-debian-10/ which I followed step 9-12 to successfully install one site.

    I've also subscribed to the howtoforge to get the ISPconfig manual which I intend to study quite a bit tomorrow.


    Questions:
    1) Is this a good way to go about it?
    2) Is there a better tutorial out there to install multiple sites and configure ispconfig, smtp on the perfect server
    3) to "Please delete the log files in /tmp/ispconfig-ai/var/log/setup-*" I would just use
    Code:
    sudo rm /var/log/setup-*
    ?


    Thank you very much for any suggestions/pointers!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ISPConfig installations steps are fine, the wordpress ones are not correct for this setup as they conflict with ISPConfig and the site is not managable and runs under a wrong user, you should undo them.

    Installing wordpress on an ISPConfig system is even easier and works like this:

    1) Create a website in ISPConfig.
    2) Create a database and database user in ISPConfig
    3) Upload wordpress files to the websites 'web' folder e.g. by FTP.
    4) Open the URL of the website and follow the instructions of the wordpress installer on the screen.


    or

    1) Create a website in ISPConfig.
    2) Use the ISPConfig APS installer to install wordpress.

    yes, that's fine.
     
  3. Newbie19

    Newbie19 New Member HowtoForge Supporter

    Hi Till, thanks for the very quick reply!

    getting an error when running the APS installer - update package list from ISPconfig

    Code:
    1 String could not be parsed as XML
    Have googled quite a bit as I don't want to steal your time but
    most answers seem to not apply; eg fixed in 3.0.5.4p8 and older versions.

    Kind Regards
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no easy answer for this, it is not an issue in ISPConfig, the initial problem report has been fixed years ago and does not exist in any recent ISPConfig version. The message basically means that the apscatalog servers did not return a valid response, this can mean that the connection from your system was not possible or that the response was incomplete due to a bad connection or that the servers delivered an invalid result for whatever reason.

    I just ran a test here with the current ISPConfig release and the aps package updated finished without error.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Btw. Personally I never use the APS installer on my systems, I prefer installing WordPress the other way I explained as this gives me full control over the installation and lets me chhose a database name etc.
     
  6. Newbie19

    Newbie19 New Member HowtoForge Supporter

    Hi again,

    did it the manual way as per your suggestion, and with lots of help of good old google and your (and others) many helpful responses all over this forum.

    Hopefully last question: to enable wordpress to install plugins I changed the "plugins" directory manually to 777 attribute,
    is this good practice or is there a better way?

    Kind regards.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This is really bad especially as its not nescessary, undo thzat and change it back to 755.

    I guess you probably used third party instructions instead of following my directions above to use an FTP or shell user of the website as this ensures that wordpress file owner is correct so everything will work out of the box. If you sued the root user instead of a user of the website, then all files are woned by a wrong user which causes WordPress to fail until you fix the file ownership. All files in the 'web' folder of the site must be woned by the webID user and clientID group of that website.
     
  8. Newbie19

    Newbie19 New Member HowtoForge Supporter

    Hi Till,
    I followed your instructions as in FTP but they weren't very detailed and yeah did use root user...
    not because of another guide just because I'm a complete newbie...
    will try and fix it now, thanks for your patience, have a great weekend!
     
    till likes this.
  9. adamjedgar

    adamjedgar Member

    The safest way to ensure you are on the correct user for WordPress is to log into ftp with the client account that the WordPress site belongs to.

    For example
    If i create a client account in ispconfig called Adam, then WordPress ownership and permissions would be
    Adam:Adam
    755 for all folders and 644 for all files in your public_html/WordPress directory

    This is the correct way to ensure WordPress functions correctly...particularly if you want to be able to install plugins and themes from WordPress own admin dashboard.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Just to not cause any confusion, the directory name that @adamjedgar meant is 'web' and not 'public_html'.
     
    adamjedgar likes this.
  11. Newbie19

    Newbie19 New Member HowtoForge Supporter

    @adamjedgar @till thanks for both your help. Got it to work. Hoora. Next SMTP. lol. :)
     
    till likes this.
  12. adamjedgar

    adamjedgar Member

    Whoops...yes that's right. My bad habits got the better of me
     

Share This Page