HowTo - upgrade openSuSE 11.4 to 12.1

Discussion in 'HOWTO-Related Questions' started by Landis, Jan 19, 2012.

  1. Landis

    Landis New Member

    Hello,
    First, love your site, Спасибо.

    Second, Your 'howto' on updating openSuSE 11.4 (KDE 4.6) to 12.1 (KDE 4.7) has been the easiest to understand. However, when I try to update with either zypper or YaST2 I get somewhere between 96 and 192 packages that they (the system) wants to 'DISINSTALL' Not update or upgrade..
    text list of files to deinstall per YaST2
    zypper text from console:

    active repos via zypper console
    *note: I made sure I was up to date in 11.4, before I disabled the 11.4 repositories per your instructions.

    I started to go thru them, but they are saying the a package need x file, but nothing supplies that file... options, deinstall, break dependency, etc.

    screenshots of YaST2 errors:
    YaST2 upper portion
    YaST2 lower portion

    Please help, I have 7 systems in my house, all running some release of SuSE / openSuSE and this is the only one that gives me trouble and it's the only one running 11.4 (KDE 4.6) so I think it's the 11.4 because my 11.2 and 12.1 systems work great. The changes in 12.1 (KDE 4.7) over 11.4 are not numerous, but enough that 12.1 works much better.

    Thank you.
    Landis.
     
  2. falko

    falko Super Moderator

    I think I'd try the second or third option, but I can't guarantee that this will not break your system. Please try at your ow risk.
     
  3. Landis

    Landis New Member

    tried using yast2.. sucked.
    booted to console and found 'welcome to opensuse 11.4 'Celedoni' or something.
    So, system was NOT updated.
    tried zypper dup, but because of the route errors from me to suse anything 1226 packages are taking days to 'time out' and retry... it's killing me.
    If the zypper replacing Everything does not work, I WILL replace All my SuSE/openSuSE systems and servers with????? maybe fedora. (any opinions on replacement os?)

    oh, inbetween using YaST2 and zypper, I was able to boot to desktop (KDE 4.7) but could no longer load YaST2 software manager.. failed in update and packages.
    Used zypper to up yast* and then on reboot had, Everytime, no mouse or keyboard.

    tried booting 12.1 iso DVD and Net CD, but video would drop Everytime, after loading usb, network drivers, no matter what I did...

    waiting on zypper and opnesuse.de network timeouts..

    impatiently,
    Landis.
     

Share This Page