Howto setup websvn on my Ds210j Diskstation.

Discussion in 'HOWTO-Related Questions' started by simolokid, Nov 6, 2010.

  1. simolokid

    simolokid New Member

    Hi all,

    I've followed the 'tutorial' on

    to installing svn + websvn. I seem to have made a mistake somewhere but I can't seem to find out where or what.

    When I try to reach websvn trough my browser ( i get the message:
    Which is weird, because I've gotten no clue where its getting the second 'svn' from.

    In my config.php from websvn:

    $config->addRepository('Test', 'file:///volume1/svn/test');
    Just like the tutorial said.

    I also came across this thread of this same forum:

    Did the which svn command, which outputted: /opt/bin/svn
    Which you can see, i set as $config->setSvnCommandPath

    Safemode is off.

    Does anyone have an idea?

    A butt-load of thanks to anyone able to fix my problem.

    Kind regards,


    Just to be clear; svn is working, its just websvn that cant find the tool apparently, since I just tried adding another repository, whichs works fine trough the cli. So websvn is the problem im guessing.
    Also tried setting the command path to '/opt/bin' instead of /opt/bin/svn which did cause the good path, but didnt result in finding the tool.
    Last edited: Nov 6, 2010
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -la /opt/bin/
  3. simolokid

    simolokid New Member


    I included the output in the printscreen, you notice I blanked my username.

    I hope this gives your some more info =P

    Attached Files:

  4. falko

    falko Super Moderator ISPConfig Developer

    Looks ok.

    Do you maybe need to reload or restart something so that the change takes effect?
  5. simolokid

    simolokid New Member

    Restarted apache 3 times so far >.<
  6. glenn85

    glenn85 New Member

    Simolokid, did you already find a solution to this? I seem to have the exact same problem on my ds210j.
    At first I thought it was something with the ownership of svn, but changing it to admin:users didn't change anything though...

    edit: I found the solution by appending 'open_basedir' of '/usr/syno/etc/php/user-setting.ini' with '/opt/bin:'
    So it was quite an easy solution after all... :D
    Last edited: Mar 8, 2011

Share This Page