Howto ledgersmb ubuntu 10.04 - error message

Discussion in 'HOWTO-Related Questions' started by Ashlacoste, Mar 12, 2011.

  1. Ashlacoste

    Ashlacoste New Member

    Hi all

    I followed your howto install ledgersmb published on the website:

    OS: ubuntu 10.04

    However when I logon using http://localhost/ledgersmb/

    It goes through successfully but when I enter my password it pops out the following error message below:


    LedgerSMB/Session/ Fetch sequence id:
    ERROR: function md5(double precision) does not exist
    LINE 1: SELECT nextval('session_session_id_seq'), md5(random());
    HINT: No function matches the given name and argument types. You might need to add explicit type casts.

    Any suggestion will highly appreciated

  2. Ashlacoste

    Ashlacoste New Member

    Hi all

    I managed to solve my problem after a sleepless night yesterday. What I did is:

    I went to the directory "/usr/local/ledgersmb/LedgerSMB/Session" and found the file.

    Opened the file for editing and where it says:

    $dbh->prepare("SELECT nextval('sessione_session_id_seq'), md5(random());");

    change to

    $dbh->prepare("SELECT nextval('session_session_id_seq'), md5(random()::text);");

    obviously you need to have privileges to edit the file.

    Then the last step was to restart the apache server.

    Walaah! it worked like charm.


Share This Page