HOWTO Install PHP 7.1, 7.2 and 5.6 as PHP-FPM & FastCGI for ISPConfig 3 on Debian 9

Discussion in 'Installation/Configuration' started by tanaka141, Nov 22, 2019.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Restart the fpm daemon of the default php version with systemctl command to see if it works then. if not, check the Linux syslog for errors.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Ubuntu 16.04 ships with 7.0, ubuntu 18.04 ships with 7.2 - did you happen to upgrade from 16.04 to 18.04 with this same ISPConfig install? If so, be sure you update all the php settings under System > Server Config > {server} > Web > PHP Settings, not just the socket directory.

    FWIW, I have switched to using a generic /var/lib/ispconfig/php for the socket directory so that doesn't have to be updated at each OS update, though of course all the other settings do.

    If this was indeed your case, you might head over to https://git.ispconfig.org/ispconfig/ispconfig3/issues/5310 and thumbs-up that issue.
     
  3. tanaka141

    tanaka141 New Member

    i can't restart the default php-fpm, because it is already open by the website which turn on php-7.2-fpm...

    Code:
     systemctl status php7.0-fpm.service
    ● php7.0-fpm.service - The PHP 7.0 FastCGI Process Manager
       Loaded: loaded (/lib/systemd/system/php7.0-fpm.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Mon 2019-12-30 19:30:51 CET; 17s ago
         Docs: man:php-fpm7.0(8)
      Process: 32760 ExecReload=/bin/kill -USR2 $MAINPID (code=exited, status=0/SUCCESS)
      Process: 20720 ExecStart=/usr/sbin/php-fpm7.0 --nodaemonize --fpm-config /etc/php/7.0/fpm/php-fpm.conf (code=exited, status=78)
     Main PID: 20720 (code=exited, status=78)
    
    Dec 30 19:30:51 serveur2 systemd[1]: Starting The PHP 7.0 FastCGI Process Manager...
    Dec 30 19:30:51 serveur2 php-fpm7.0[20720]: [30-Dec-2019 19:30:51] ERROR: An another FPM instance seems to already listen on /var/lib/php7.0-fpm/web9.sock
    Dec 30 19:30:51 serveur2 php-fpm7.0[20720]: [30-Dec-2019 19:30:51] ERROR: FPM initialization failed
    Dec 30 19:30:51 serveur2 systemd[1]: php7.0-fpm.service: Main process exited, code=exited, status=78/n/a
    Dec 30 19:30:51 serveur2 systemd[1]: Failed to start The PHP 7.0 FastCGI Process Manager.
    Dec 30 19:30:51 serveur2 systemd[1]: php7.0-fpm.service: Unit entered failed state.
    Dec 30 19:30:51 serveur2 systemd[1]: php7.0-fpm.service: Failed with result 'exit-code'.
    
     
  4. tanaka141

    tanaka141 New Member

    web9 was for the website with 7.2, then i stop all php-7.x-fpm and remove the sock file for web9.
    the 2 websites are now fully functionnal :) , but web9 is down :D

    Not very down, only script that didn't show anything...

    i change php-pfm for web9 setting it to default, then it return on live !
     
    Last edited: Dec 30, 2019

Share This Page