Howto get rid of Apache2 vhosts errors on restart/reload

Discussion in 'Installation/Configuration' started by alecvannoten, Apr 25, 2013.

  1. alecvannoten

    alecvannoten New Member

    Hi guys,

    Currently running the latest ISPconfig on debian 6 fully updated and patched etc.

    but how the hell do you get rid of these apache errors on restart/reload config?

    Code:
    Restarting web server: apache2[Thu Apr 25 08:02:54 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Thu Apr 25 08:02:54 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
     ... waiting [Thu Apr 25 08:02:55 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Thu Apr 25 08:02:55 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
    I already activated create vhost for IP etc...
    what to do?
    maybe it's something overlooked in ISPconfig?

    Maybe it's a great solution you can set default site for ip/hostname/wildcard somewhere?
     
  2. till

    till Super Moderator

  3. alecvannoten

    alecvannoten New Member

    Hi,

    I already passed this thread, but now when i surf to the server hostname / ips I go to the first website it finds in its configuration?

    can't I set up a default site to show when IP/hostname is entered?
     
  4. till

    till Super Moderator

    Thats the normal behaviour of the apache webserver.

    Thats possible off course, create anwe website and use as domain:

    0000default.tld

    to ensure that it is the first site in alphabet on this IP or *.
     
  5. alecvannoten

    alecvannoten New Member

    Thanks Till, problem solved!
     

Share This Page