howto force the ispconfig webinterface access to https ?

Discussion in 'Installation/Configuration' started by sdi, Apr 20, 2016.

  1. sdi

    sdi New Member

    Hi,
    I have succesfully installed a freessl certificate on my IspConfig 3 / Debian 8 host.
    Direct access over https://example.com:81 works.

    But what I don't figure out is how to force an automatic forward from http to https, so if I try to access the ispconfig webinterface panel via HTTP it will automatically be redirect to HTTPS.

    when trying to access http://example.com:81 I get an error like this:
    Code:
    Bad Request
    
    Your browser sent a request that this server could not understand.
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.
    So I would prefer doing an automatic forward to https:// instead

    I don't know how to do this properly.
     
  2. Jesse Norell

    Jesse Norell Active Member

    To redirect http to https, the two services must be running on different ports. Eg. if 81 is https, you could redirect http://example.com/ to https://example.com:81/, but you can't redirect http on port 81 to https on port 81.

    Granted that the server is returning that error to your HTTP client, it seems like you should be able to do so (ie. why couldn't you include a Location: along with that error?), but in my searching I have not seen any indication that it is supported/possible.
     

Share This Page