Howto enable apache server-status for ISPConfig

Discussion in 'Installation/Configuration' started by chillifire, Dec 21, 2008.

  1. chillifire

    chillifire New Member

    Hi, I wanted to enable apache server-status through mod_status while running under ISPConfig. I needed that to show not just whether the acpache server was up, but also how long it was up. For this purpose I added the following directives to the site definition in ISPConfig
    Code:
    <Location /server-status> SetHandler server-status Order Deny, Allow Deny from all Allow from login02.chillifire.net </Location>
    However, when I access http://login02.chillifire.net/server-status, I get a 403, access denied error The same when I replace with
    Code:
    <Location /server-status> SetHandler server-status Order Deny, Allow Deny from none </Location>
    This gives me the same error. I checked the directory and all things seem to be owned by web1_admin:web1, as you would expect. Except when I go to /var/www I get the following files:
    Code:
    -rw-r--r-- 1 root root 45 May 2 2008 index.html drwxr-xr-x 3 root root 4096 Mar 3 2008 localhost drwxr-xr-x 3 root root 4096 Dec 18 00:30 localhost.localdomain lrwxrwxrwx 1 root root 13 Feb 28 2008 login02.chillifire.net -> /var/www/web1 drwxr-xr-x 2 root root 4096 May 27 2008 sharedip drwxr-xr-x 8 web1_admin web1 4096 Dec 21 12:29 web1 
    I tried to
    Code:
    chown web1_admin:web1 login02.chillifire.net 
    as root,, but the system executes the command without error - oly to leave this symlink owned by root:root. That is as far as my Linux knowledge carries me and I am out of ideas how to overcome this 403 issue. I have Ubuntu 8.10 machines, running ISPConfig 2.2.23 and relating apache2 versions. Any hints welcome. Thanks
     
  2. Leszek

    Leszek New Member

    Undo everything You've done so far and enter:
    Code:
    a2enmod status
    and restart Apache:
    Code:
    /etc/init.d/apache2 restart
    Now You should see this module working. By default it's bound to 127.0.0.1 so You can't see it from anywhere else. Take a look at status.conf in /etc/apache2/mods-available to adjust it's settings.
     
  3. chillifire

    chillifire New Member

    Thanks

    The status module was already enabled. I obviously did not make myself clear enough.

    But I did find the relevant config is actually in status.conf, and thus does not need to go into the additional site directives in ISPconfig.

    Problem solved
     

Share This Page