HowTo configure Outlook

Discussion in 'Installation/Configuration' started by schmidtedv, Jul 31, 2006.

  1. schmidtedv

    schmidtedv New Member

    HowTo configure Outlook (FIXED)

    Well,
    I'm having difficulties sending Mails, so I guess there must be something wrong...

    lets say server is www.xyz.de...

    Username as in ISPConfig would be web2_002
    Password lets say is Dingdong

    SMTP and POP3 would be mail.xyz.de ?

    This config brings me the wrong username or password window for smtp in Outlook....same for normal pop3-account and if I would try to use it as Imap-account.

    Before I would think of an configuration-error or missbehavior in ISPConfig, I thought, I did something wrong, so, is there a manual, what I would have to enter for username, password, smtp, pop3, authentification or even SSL to get/send my mails?
     
    Last edited: Aug 23, 2006
  2. Ben

    Ben New Member Moderator HowtoForge Supporter ISPConfig Developer

    I would do the following options in case of POP3:

    Username: web2_002
    Password: Dingdong
    SMTP AND POP3: Any DNS-Name pointing to your servers IP (or the IP directly)

    Then you should go to "advanced options" or sth. like that, where you have to define authentication for smpt-Server and check the radio "same as for POP3" or anything like that.

    That should work fine, I had no problems with that.
     
  3. schmidtedv

    schmidtedv New Member

    ...that might work...but I shouldn't give customers the IP in normal case, there should be their domain in smtp and pop...shouldn't it?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    That's up to you. Either any domain that points to your server or the IP.
     
  5. schmidtedv

    schmidtedv New Member

    okok, but then, would it have to be in format mail.xyz.de with debian 3.1 howto for smtp and pop3? I did this and authorisation didn't work for smtp...
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No. You can use ANY domain that points to your server.
     
  7. schmidtedv

    schmidtedv New Member

    ok, well, then there seems to be something wrong...I put the FQDN as smtp and IMAP, both tried with and without SSL, but it doesn't work.

    The Domain has it's own IP (from 3) and in DNS-Manager the Nameservers are (is that correct?) both the same (FQDN from first IP I used and installed ISPConfig on). In the Records the IP for the Domain, I'm testing, is the one I wanted this Domain to be onand the only other entrance here is the Mailserver which again points with it's FQDN to the main ISPConfig-IP/Domain.

    I can use RoundCube without errors, but to get in from the outside, there seems something misconfigured by me?

    The provider gave me for the 3 IP's 3 own Reserve-DNS entrances....maybe I would have to use the one for the particular Domain/IP in the Records?
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you post your public IP addresses here? Did you try the IP addresses in your email client (to see if it works)?
    What's the domain name you're trying to set this up for?
     
  9. schmidtedv

    schmidtedv New Member

    I didn't tried the IP's, only the FQDN for the Main-IP...should I? Well, IP is 84.16.xxx (but I will take that out again, becaouse I get many hackers-login-tries allready...)
     
    Last edited: Aug 15, 2006
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Yes, try your IP address. IF this doesn't work, then it's not a problem with DNS, otherwise it most probably is.
     
  11. schmidtedv

    schmidtedv New Member

    Well, even the IP doesn't let me in...I get the Screen for re-enter password or username and that's it...

    Actually, the problem with the login-screen not working (mentioned shortly before) still remains...after a couple day's I (don't know how else I could get it working again) have to reboot the server to get the ISPConfig Login Screen up again (domains are working without this kind of issue).

    I thought I did everything right by following the perfect sarge setup and all the informations I found here, but maybe there are some errors in my knowledge of what informations I got from the hoster...

    Actually IP for the domain I'm testing is 84.16.250.217 ...
     
    Last edited: Aug 15, 2006
  12. schmidtedv

    schmidtedv New Member

    Ok, another thought for the SMTP-Problem....there seems to be something wrong with SASL.

    resolf.conf for local server:

    hosts:

    interfaces:

    main.cf:

    Getting into IMAP or POP3 Inbox in Outlook is no problem, but having mails sent over SMTP is not possible....I'm getting crazy by figuring what's going wrong here... :-(
     
    Last edited: Aug 22, 2006
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's that?
    The line should be
    Code:
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    instead in /etc/postfix/main.cf.
     
  14. schmidtedv

    schmidtedv New Member

    well, actually, I don't know, where that came from...only things I did where the ISPConfig-Updates and apt-get updates that came out till now...

    what does this line do? ...i will check without right now...

    EDIT: even without there is no effort in SMTP-Auth (the line belongs to postgrey...)
     
    Last edited: Aug 16, 2006
  15. schmidtedv

    schmidtedv New Member

    Just to get this Topic closed, the solution was quite simple, but not found right away:

    main.cf had smtpd_sasl_local_domain = $myhostname in line, that was mentioned in the tutorial-code-box (now fixed by falko). This should, so sasl doesn't get bounded to a specific domain, left empty, as mentioned in the postconf-command by falko (above the code-box in tutorial)!

    THANKS TO FALKO as he finally picked this up by looking in main.cf on the live system.
     

Share This Page