Howto activate paypal for all clients

Discussion in 'ISPConfig 3 Priority Support' started by elmacus, Oct 29, 2019.

Tags:
  1. elmacus

    elmacus Active Member HowtoForge Supporter

    Howto activate paypal for all clients in billing module ?
    I see that i can set payment-gateway to auto in invoice and on client in billing module, but is there a way do all clients ?
    And as standard for all new clients ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The only way to change it for all clients is to use an SQL query to update the invoice_client_settings table.

    You'll have to change line 70 in /usr/local/ispconfig/interface/lib/plugins/billing_plugin.inc.php as that's the code which inserts the record into invoice_client_settings when a new client is added.
     
  3. elmacus

    elmacus Active Member HowtoForge Supporter

    Even if i set billing-client to gateway = auto, before i create new invoices, i still need to set gateway to auto on the invoice itself afterwards.
    This must be a bug ?
    Please make this easy setting for next update, we autogenerate links to all clients.
     
    Last edited: Oct 29, 2019
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Just tested it here and it works for me:

    1) Created a client.
    2) Set Payment gateway to auto in client settings.
    3) Created a recurring item for the client.
    4) ran 'Make invoices', the generated invoice has payment gateway set to auto.
     
  5. elmacus

    elmacus Active Member HowtoForge Supporter

    3) all our recuring items is created long time ago. Not after changing payment gateway in client.
    Could be that.
    Try the other way around.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This does not matter, the value is stored in client settings and read at the time the invoice gets created. I just had to create a recurring item as I won't be able to create an invoice for it otherwise.
     
  7. elmacus

    elmacus Active Member HowtoForge Supporter

    I tested 2 clients + creating new invoice from recurring items, failed setting gateway to auto on both.
    Will now try setting all clients via phpmyadmin: SQL query to update the invoice_client_settings table.
    I report back after making some more invoices.

    Anyway, next version for Billing should have this on Auto for all clients. We do have a Paypal ON/Off in global settings if someone needs to turn this off.
     
  8. elmacus

    elmacus Active Member HowtoForge Supporter

    It could also be nr 4). we created invoices from the Order and then Invoice Action manually, not "Make invoices".
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Then that's the reason. As far as I know, the presets are for the recurring invoices only. I'll make a note to implement it as default for manually created invoices too.
     
  10. elmacus

    elmacus Active Member HowtoForge Supporter

    I still fell there is a bug here.
    I have edited in database so all invoice_client_settings has payment gateway = auto, so Paypal link should work.
    But anyway new invoices and reminders from recuring items still have gateway to NONE. I dont understand this.
    >Payment page has been disabled for this invoice.

    So we have set all clients to Auto in database:
    invoice_client_settings/payment_gateway
    And after creating new recuring-items, invoices is still NONE in:
    invoice/payment_gateway

    Anyway we will try a cron jobb to automatically set it to AUTO for both invoices and clients. We dont use SEPA.
    .
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    I'm not able to reproduce your issue. Tested it again today with a new setup and it still works. invoices created by 'make recurring invoice' have set payment gateway to auto when payment gateway is set to auto in the client settings.
     
    elmacus likes this.

Share This Page