How to view the php file which is located in hadoop path?

Discussion in 'Server Operation' started by mariaprabudass, Sep 21, 2011.

  1. mariaprabudass

    mariaprabudass New Member

    Hi all,

    I have copied my files using hadoop in the following path "/user/hadoop/input" path. Now i need to open the "index.php" file which located in the above path, so i configure that path in apache. Then i tried in Ubuntu using vim 000-default and edit the below two lines.

    DocumentRoot /user/hadoop/input
    <Directory /user/hadoop/input>

    But my "index.php" not working because file(index.php) not viewed, Just throw an following error.

    The requested URL /input/index.php was not found on this server.

    Kindly check and advise me how to solve this issue.


    Thanks,
    Mariaprabudass
     
    Last edited: Sep 21, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post the full vhost configuration?

    What's the output of
    Code:
    ls -la /user/hadoop/input/
    ?
     
  3. mariaprabudass

    mariaprabudass New Member

    In hadoop we have to list the file like below command.

    [email protected]:/usr/local/hadoop$ bin/hadoop dfs -ls /user/hadoop/input


    Normal "ls -la /user/hadoop/input/" not working in hadoop. If i list via hadoop command i can view the file. So kindly advise me how to solve this issue.

    I have copied the "/etc/apache2/sites-enabled/000-default" for your review.

    <VirtualHost *:80>
    ServerAdmin [email protected]

    DocumentRoot /user/hadoop/input
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /user/hadoop/input>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>


    Thanks,
    Mariaprabudass
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I'm no hadoop expert, but maybe this is the reason it's not working - I guess Apache cannot access the file.
     

Share This Page