How To Use NTFS Drives/Partitions Under Ubuntu Edgy Eft

Discussion in 'HOWTO-Related Questions' started by rjmusto, Jan 17, 2007.

  1. rjmusto

    rjmusto New Member

    Hi,
    Have run through the set-up process for getting an external USB NTFS
    drive read/write on Ubuntu.

    Fallen into the trap of it not being mountable at the finish. I did
    eject it and switch it off, but not unplug it. Maybe that was a mistake.

    Anyhow, it won't mount now. Do you know of a fix for this?

    Many thanks
     
  2. domino

    domino New Member

    Are you using ntfs-3g? What message do you get when you try to manually mount the ext drive? Are you sure it's not already mounted in /mnt directory but not visable on your desktop?
     
  3. rjmusto

    rjmusto New Member

    As far as I know, yes I'm using ntfs-3g. How do I check?

    No, the mnt folder is empty.

    Trying to mount mannual produces this response:

    Failed to mount '/dev/sda1': Operation not supported
    Mount is denied because the NTFS journal file is unclean. Choices are:
    A) Shutdown Windows properly.
    B) Click the 'Safely Remove Hardware' icon in the Windows taskbar
    notification area before disconnecting the device.
    C) Use 'Eject' from Windows Explorer to safely remove the device.
    D) If you ran chkdsk previously then boot Windows again which will
    automatically initialize the journal.
    E) Run 'ntfsfix' on Linux which will reset the NTFS journal.
    F) Mount the volume read-only by using the 'ro' mount option.
    Error: could not execute pmount

    Thanks.
     
  4. martinfst

    martinfst HowtoForge Supporter

    Why don't you follow the suggestions the mount command gives you? Briefly scanning this thread, ntfsfix might do the trick.
     
  5. rjmusto

    rjmusto New Member

    Ok, got it to mount read only using pmount.
    Ejected, unplugged and plugged back in.
    Had to manually mount again - but it still insists its read only, even though I didn't include the ro switch.

    Is there a switch for pmount that forces read/write?
     
  6. martinfst

    martinfst HowtoForge Supporter

    You still need to fix the problem on the filesystem. So either fsck (for Linx/Unix filesystems) or chkdsk (FAT) is required.
     
  7. rjmusto

    rjmusto New Member

    Have tried fsck, but it returns this error:

    fsck 1.39 (29-May-2006)
    fsck: fsck.ntfs: not found
    fsck: Error 2 while executing fsck.ntfs for /dev/sda1


    And for chkdsk it says 'command not found'


    Sorry to be a bit of a numpty - still kind of a novice at Linux.....
     
  8. martinfst

    martinfst HowtoForge Supporter

    No problem, that's why these forums are there to get newbees up 2 speed :cool:

    Apparently you have created an ntfs filesystem, so you need the 'ntfsfix' command. I think that's not installed by default (you'll notice if you get an obvious error), so you may need to install that using the specifics of your distro.
     
  9. domino

    domino New Member

    If you run any disk util to fix ntfs under Linux, you will probably have little success. you need to do it in windows or use use a a dos disk with chkdsk compatible to winxp.

    Keep in mind that read/write feature can only be mounted with sudo command. Make sure you have the latest version of ntfa-3g from givre's repo or the repo posted on his thread.

    Make sure you don't have anything that involves your ext. drive in fstab.
     
  10. rjmusto

    rjmusto New Member

    Ok, thanks for all that.

    May be a while before I get back to you on this........
     
  11. falko

    falko Super Moderator

    I solved it by plugging the USB HDD into my Windows XP notebook and clicking on that green arrow in the task bar to securely remove the HDD before switching it off.

    Afterwards I could use it again under Ubuntu.
     

    Attached Files:

  12. rjmusto

    rjmusto New Member

    Crumbs - so simple in the end.

    Plugged it into a Windows machine, ran a check disk routine and then ejected it.

    Now loads up fine with read/write capability.

    Phew.

    Thanks for the help and on providing the info to get NTFS working on a Linux machine.
     

Share This Page