How to Use Multiple PHP Versions

Discussion in 'Installation/Configuration' started by conductive, Oct 9, 2014.

  1. conductive

    conductive Member

    I have a ispconfig3 running NGINX on Wheezy. I can serve pages using the "Default" setting.

    When I run any of the installed Multiple versions the pages lack color/content as if I was trying to parse .php as html.

    I do not see any errors in the the global logs or in system test. The php versions are all listening and run phpinfo. Since there are no errors I am assuming that I am not setting up something properly in the control panel or need to add something to the options > base dir or other.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. conductive

    conductive Member

    I am not sure what the problem is but the only version I can run is the default version which phpinfo says is 5.4.4

    Any other selection gives me

    HTML:
    ERROR 502 - Bad Gateway!
    
    Note:
    After removing all index.htm? files and re-uploading what may have been many corrupt sites. I have been able to parse .php files but not php files with the .htm? extention as I could in apache with the proper directive.
    The only problem is that I can not see my php version with phpinfo when I get the 502 error
     
    Last edited: Oct 27, 2014

Share This Page