How to upload a big SQL file

Discussion in 'Tips/Tricks/Mods' started by AngelDrago, Feb 1, 2009.

  1. AngelDrago

    AngelDrago Member

    Hello Everyone how do i overcome this problem with out using remote tools... what i like to use is phpmyadmin...

    this is the error message i'm getting..
    You probably tried to upload too large file. Please refer to documentation for ways to workaround this limit.

    thank you..
     
  2. Antennipasi

    Antennipasi ISPConfig Developer ISPConfig Developer

    one have to edit php.ini values to increase limits. in my install i have couple developers who prefers also phpmyadmin, and i have increased values like this:

    Code:
    in /etc/php5/apache2/php.ini:
    max_execution_time = 60     ; Maximum execution time of each script, in seconds (def. 30)
    max_input_time = 90 ; Maximum amount of time each script may spend parsing request data (def. 60)
    memory_limit = 128M      ; Maximum amount of memory a script may consume (def. 128mb)
    upload_max_filesize = 16M ; Maximum allowed size for uploaded files. (def. 2mb)
    post_max_size = 16M ; (def. 8mb)
    don't forget to reload apache after modify. those are quite big numbers, one should adjust them to fit to demands.
     
  3. falko

    falko Super Moderator ISPConfig Developer

  4. make-fun

    make-fun Member

    You could also look into a phpMyAdmin config option.
    Have a look at your
    Code:
    phpmyadmin/config.inc.php (and for info phpmyadmin/config.sample.inc.php)
    Code:
    /**
     * web-server upload directory
     */
    $cfg['UploadDir']   = ''; // [B]Directory for uploaded files[/B] that can be executed by
                              // phpMyAdmin. For example './upload'. Leave empty for
                              // no upload directory support
    You should be careful and evaluate who is using phpmyadmin.
    Customizing this file, so user can upload only within their allowed path maybe an option…

    Edit:
    Code:
    UploadDir
    
    Directory where SQL files can be uploaded by means other than phpMyAdmin (for example with FTP).
    This allows file import even if file uploads are disabled in php.ini. For example './upload'.
    Leave empty for no upload directory support. Use %u for username inclusion.
    Note: the dropdown file select field is only shown after a file was successfully uploaded.
    
    $cfg['UploadDir'] = '';
    
     
    Last edited: Feb 3, 2009
  5. khubab1

    khubab1 New Member

  6. Dennis_sp

    Dennis_sp New Member

    I'm trying to simply upload a Wordpress database of 9MB through phpmyadmin and it's telling me there is some kind of limit and the upload failed.

    I configured these options:

    upload_max_filesize = 500M
    memory_limit = 512
    post_max_size = 500M

    I changed this in:
    /etc/php/cgi/php.ini
    /etc/php/cli/php.ini
    And under the website in the Options tab under the ISPconfig interface.

    Still can't upload :-(

    Anyone know how to upload a file of 9MB?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You posted here in a Forum about ISPConfig 2, but I guess you use ISPConfig 3, right?

    phpmyadmin is a globally installed application, it is not running under a specific website, so website options do not apply to it. If you use an apache web server, then the php.ini file used by phpmyadmin is /etc/php/apache2/php.ini and you'll have to restart apache after altering that file.
     
  8. Dennis_sp

    Dennis_sp New Member

    Yes, this was an old thread and the first found by google, i'm using ISPConfig 3 indeed. And i did find the correct php.ini file in the meantime, thanks for the quick response!
     

Share This Page