How to update SSL LetsEncrypt on port 443

Discussion in 'Installation/Configuration' started by Don Gould YourNet, Jul 7, 2020.

  1. Don Gould YourNet

    Don Gould YourNet New Member

    I'm getting emails from LE telling me I need to update my cert.

    I created following the instructions in the link above, but I didn't want the panel on port 8080 so I deleted the 'site' I had made for and change the config so that the panel is on port 443.
    The problem is that without the 'site', my cert doesn't get updated.
    How do I manually update the cert so that I can just add that command to the crontab so it just does that cert and then pushes the cert to the mail system?
  2. Don Gould YourNet

    Don Gould YourNet New Member


    A backup copy of the domain cert config still existed in /etc/letsencrypt folder.
    I copied the backup back to the correct name (following the obvious conventions) then ran certbot. It prompted me to select the domain to generate an SSL cert for, then asked me to confirm which Vhost file (which is the ispconfig.vhost one) and then asked if I wanted to force ssl (option 2).
    I asked it to force ssl, but this didn't work (and it told me such). Not sure why. However the base domain now works as desired.
    I then had to run the ssl mail transfer script to copy the certs into the mail system (see the instructions for setting up ssl on mail, I just ran the script in ecrontab).

    (ADMIN - You could edit 'solved' into the title of this thread, I tried but it wouldn't let me in firefox on Debian on this machine, odd) :)

Share This Page