How to turn register globals on just for one site

Discussion in 'Installation/Configuration' started by IKShadow, Nov 21, 2006.

  1. IKShadow

    IKShadow New Member

    I would need to turn register globals on just for one site.
    How can I do it with apache directive... any idea.

    If I put in .htaccess
    php_flag register_globals on

    I get 500 Internal server error.

    If I put it in Apache Directives:
    php_flag register_globals on

    It does not work.
    Last edited: Nov 21, 2006
  2. edge

    edge Active Member Moderator

    Try this in the Apache Directives:
    php_admin_flag register_globals on
    and nothing in the .htaccess

    it's working fine for me!
  3. IKShadow

    IKShadow New Member

    forgot to mention it I tried that too. (did not work)

    I did use search before I posted.

    Thanks anyway.
    Last edited: Nov 21, 2006
  4. IKShadow

    IKShadow New Member


    I also change /etc/apache2/default-server.conf
    (bold part)

    <Directory "/srv/www/htdocs">
            # Possible values for the Options directive are "None", "All",
            # or any combination of:
            #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
            # Note that "MultiViews" must be named *explicitly* --- "Options All"
            # doesn't give it to you.
            # The Options directive is both complicated and important.  Please see
            # for more information.
            Options None
            # AllowOverride controls what directives may be placed in .htaccess files.
            # It can be "All", "None", or any combination of the keywords:
            #   Options FileInfo AuthConfig Limit
            [B]AllowOverride all[/B]
            # Controls who can get stuff from this server.
            Order allow,deny
            Allow from all
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This solved your problem? The allow override options do not limit the values in the apache directives window. I guess you put the php_admin_flag setting in a .htaccess file instead of the apache directives field as edge mentioned.
  6. IKShadow

    IKShadow New Member

    No i did not.

    I put apache directives.
    php_admin_flag register_globals on
    php_admin_flag register_long_arrays on

    And i also check phpinfo for that site and it has register globals on , all my other sites have it off.
  7. falko

    falko Super Moderator ISPConfig Developer

    So it's working now for that web site?
  8. IKShadow

    IKShadow New Member

    yes its working.

    p.s. I tried to remove it from apache directives and put it only in .htaccess file but it does not work then.
  9. falko

    falko Super Moderator ISPConfig Developer

    Because you need to change the AllowOverride setting then.

Share This Page