how to temporarily disable a website

Discussion in 'General' started by Ovidiu, Apr 18, 2012.

  1. Ovidiu

    Ovidiu Active Member

    using ispcfg 3 on debian squeeze according to the perfect debian server setup with apache2

    I edited the website inside ispcfg3 and und unchecked the active check box.
    waited a few minutes for the system to write the changes then visited the web site and it is still accessible via browsers...

    Am I doing something wrong?

    I need to make this site inaccessible to the public till some problems are solved.
     
  2. kwickcut

    kwickcut Member

    you may have to clear your browser chache or you can try a hard refresh by hitting ctrl/F5 at the same time
     
  3. Ovidiu

    Ovidiu Active Member

    tried that already, different browsers and different computers, the site was still showing up :-(
     
  4. till

    till Super Moderator

    Disabling the site the way you did it should work. Are there any jobs listed in the jobqueue of the ispconfig monitor?
     
  5. Ovidiu

    Ovidiu Active Member

    - nothing in the job queue
    - activating the site, saving, waiting 5 minutes, deactivating, saving waiting 5 minutes and the site is still accessible
    - the sites are disabled: http://screencast.com/t/L9ROzx8jWG
    - but they can still be accessed: http://www.quilombobrasil.com

    What else should I check? What is deactivating actually doing? Is it physically moving this vhost from apaches2/sites-enabled/ to apache2/sites-available/ ?
    If that is all that happens, I can manually do it...

    The reason I want these two websites deactivated is because the owner is MIA and the sites need some updating... its using really old and probably vulnerable stuff :-(

    I don't know if this is a problem, but these two vhosts I would like to disable look like this: quilombobrasil.com.vhost
    after enabling/disabling and saving a few times, now I have two vhosts: quilombobrasil.com.vhost and 100-quilombobrasil.com.vhost.
    Saved again, and now it is again only quilombobrasil.com.vhost - can I manually fi this somehow?
     
    Last edited: Apr 19, 2012
  6. till

    till Super Moderator

    In sites-enabled are only symlinks, so no file is moved. Deactivating a site removes just the symlink in sites-enabled and when you activate the site, the symlink is created again.

    Please delete the symlink in sites-enabled manually and then reload apache to deactivate the site.
     
  7. Ovidiu

    Ovidiu Active Member

    weird. all vhosts that start with 000- and 100- inside /etc/apache2/sites-enabled/ are symlinks.
    All other vhosts are not symlinks.

    I deleted quilombobrasil.com.vhost restarted apache, waited, checked again and now everything works as expected: activating and deactivating properly creates/deletes symlinks.

    I think I need to do this with all vhosts that are not symlinks...

    Thanks for helping me out.
     

Share This Page