How to setup RoundCube to work with ISPConfig 3?

Discussion in 'Developers' Forum' started by quentusrex, Oct 30, 2008.

  1. quentusrex

    quentusrex New Member

    I'd like to either know where squirrelmail is hiding, or how to setup RoundCube. I'm searching for the info myself, but if someone knows and can point me in the right direction I'd appreciate it.

    I have until Nov. 1st, to have a semi production ready server with ISPConfig3. So... I'll donate tons of time if I can get a little help with the directions. :)
     
  2. quentusrex

    quentusrex New Member

    I will try to get roundcube up and running with:

    http://cad.cx/blog/2007/08/11/howto-install-roundcube-webmail-on-ubuntu-feisty/


    I will post all of my steps and solutions.

    In ubuntu 8.04.1:

    apt-get update
    apt-get upgrade
    apt-get install roundcube-webmail

    There are the following errors that probably need to get fix somehow.
    Restarting apache2...
    * Restarting web server apache2 [Wed Oct 29 17:31:30 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Wed Oct 29 17:31:40 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [ OK ]




    cd /usr/share/roundcube-webmail
    cp ./config/db.inc.php.dist ./db.inc.php
    cp ./config/main.inc.php.dist ./main.inc.php

    Open up phpmyadmin, Go to permissions, Add a new user, create the database as well, grant all permissions.

    Edit db.inc.php and change the database connection settings
     
    Last edited: Oct 30, 2008
  3. quentusrex

    quentusrex New Member

    Does anyone know of a good way to setup RoundCube so that the clients can go to webmail.theirdomain.com to access it? I'm asking what would be the proper ISPConfig 3 way to enable this.
     
  4. quentusrex

    quentusrex New Member

    I got it to work. It needs to be cleaned up a bit, but it works just fine now. Here are the steps:

    1. mkdir /usr/share/roundcube
    2. cd /usr/share/roundcube
    3. wget http://voxel.dl.sourceforge.net/sourceforge/roundcubemail/roundcubemail-0.2-beta.tar.gz
    4. tar zxvf roundcubemail-0.2-beta.tar.gz
    5. cd roundcubemail-0.2-beta
    6. chmod 777 logs temp
    7. paste the following into /etc/apache2/conf.d/webmail.conf
    ###########################################
    #This is basically a modified version of /etc/apache2/conf.d/phpmyadmin.conf
    # RoundCube default Apache configuration

    Alias /webmail /usr/share/roundcube/roundcubemail-0.2-beta

    <Directory /usr/share/roundcube/roundcubemail-0.2-beta>
    Options Indexes FollowSymLinks
    DirectoryIndex index.php

    # Authorize for setup
    <IfModule mod_php4.c>
    AddType application/x-httpd-php .php

    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php

    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    </Directory>
    #########################################
    8. /etc/init.d/apache2 restart
    9. open your browser to: http://yourdomain.com/phpmyadmin
    10. Login using username 'root' and your mysql root password.
    11. Go to Privledges, and add a user called roundcube(and at the bottom tell phpmyadmin to add a database with the permissions, and grant all the permissions)
    12. open your browser to: http://yourdomain.com/webmail/installer
    13. I had to modify one of the lines in php.ini(set true to false)
    14. use the installer to setup roundcube
    15. DON'T FORGET TO DELETE THE INSTALLER DIRECTORY ONCE THE INSTALL IS FINISHED.
     
    Last edited: Nov 8, 2008
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This is caused by the default vhost from debian. Either ignore it or remove the debian default vhost.
     
  6. quentusrex

    quentusrex New Member

    That seems to have removed the error, but I think I'm missing a step. I've moved the /etc/apache2/sites-enabled/000-default to /tmp. Now I get this error:

    * Restarting web server apache2
    [Thu Oct 30 03:28:20 2008] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Thu Oct 30 03:28:30 2008] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [ OK ]


    And then I find a new file generated by apache called 'default' that is blank. So I think there is one last minor configuration to fix to get rid of the errors.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    There must be more then one vhost with _default_ in the apache configuration. you can try to search for ith e.g. with the grep command.
     
  8. quentusrex

    quentusrex New Member

    I found the fix for this problem.

    You need to add the line "NameVirtualHost *:80" into /etc/apache2/httpd.conf. This seems to be very important because if it's not there then the first vhost will be treated weird. Here is the link with the fix:

    http://www.antbrown.com/nerd-musings/virtualhost-overlap-on-port-443/

    And here are some links describing the problem of no matter which vhost they try to visit, they only can see the first vhost:

    http://www.heavymind.net/2007/07/25/virtualhosts-nightmare-on-suse/
    http://forums.devshed.com/apache-development-15/default-virtualhost-overlap-on-port-80t-37540.html



    Now that it is documented.
     
  9. d0nut

    d0nut New Member

    and as part of "use installer to complete installaition": don't forget to remove the install direcoty ;)

    many thanks...
     
  10. crypted

    crypted New Member

    Should a webmail.conf exist already in the conf.d/ folder? I do not have one.

    However, I am using Debian 5.0 rather than Ubuntu...
     
  11. u4david

    u4david New Member

    i created my own(ubuntu)
    and i named it rcwebmail.conf and changed the directives alias from webmail to rcwebmail and changed the file names to last revision of roundcube

    but when i try to browse in to the installer directory i get:
    Forbidden

    You don't have permission to access /rcwebmail/installer on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I tried 777 to the whole roundcube directory and change the owners to www-data with no luck
     
  12. jmp51483

    jmp51483 New Member


    Same issue with me... assuming it's something to do with the way it's being called? This also happens when you try to redirect /webmail to the /usr/share/squirrelmail setup.
     
  13. vogelor

    vogelor ISPConfig Developer ISPConfig Developer

    why so comlicated

    Hmm!
    i don't understand the problems, you have.
    i logged in in to ISPConfig, created a web called webmailer.mydomain.com.
    i then waited 1 minute for ISPC3 to create the site.
    then changed to the web-directory ISPC3 created.
    downloaded the roundcube files from their site, unpack then into the web-directory. then run the installer and that's al.
    no patch of any file.

    and by the way:
    if you use only ONE mailserver (only ONE webmailer) you can buy a ssl-certificate and allow SSL and TLS. you also can set the url to your webmailer in the ISPC3 Interface and so your user can click at the webmailer icon inside ISPC3 and "jump" to the webmailer login

    absolutely easy!
     
  14. BorderAmigos

    BorderAmigos New Member

    I installed RoundCube and Horde webmail packages as stand alone. Then replaced the ISPConfig3 /var/www/webmail symbolic link with a menupage /var/www/webmail/index.php that lets the user choose from any of the 3 webmail programs. Seems to work fine.
     
  15. m1_davidson

    m1_davidson New Member

    The issue here is directory ownership not directory rights. Once you identify the user & group that should own the roundcube directory - and assign ownership to the user/group, it should work fine. There is no www-data user in /etc/passwd - hence it won't work. If someone can answer the user/group ownership, the rest is easy.
     

Share This Page