How to Setup Postfix to Work with Fortimail

Discussion in 'HOWTO-Related Questions' started by BeauSanders, Oct 11, 2012.

  1. BeauSanders

    BeauSanders New Member

    I am attempting to configure a Postfix MTA in CentOS 6.3 for our school. The Postfix server has to send and receive email through a Fortimail firewall. Outgoing email is working fine. Email sent locally using the mail command to a local user on the CentOS/Postfix server works fine. However, all email coming in to the Fortimail firewall addressed to users on the Postfix server is NOT being accepted by Postfix. Inbound mail from Fortimail is being deferred and ultimately rejected by Postfix. It appears the email is being forwarded/relayed from the Fortimail firewall to the Postfix server. There are no errors on the Fortimail firewall.

    Here is the main.cf file as it is currently configured:

    Code:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    data_directory = /var/lib/postfix
    mail_owner = postfix
    myhostname = bps.gvltec.edu
    inet_interfaces = all
    inet_protocols = all
    mydestination = $myhostname, localhost.$mydomain, localhost
    unknown_local_recipient_reject_code = 550
    relayhost = [fortimail.ip.address.here]
    relay_recipient_maps = hash:/etc/postfix/relay_recipients
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
             PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
             ddd $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.6.6/samples
    readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
    
    Please advise me on what I am missing. I have not been able to locate any posts from users with similar problems. I will be happy to answer questions if somewhere will help me correct this issue.

    Thank you in advance for your help.

    -Beau
     
  2. falko

    falko Super Moderator

    Are there any errors in your mail log (in the /var/log/ directory)?

    Is port 25 open on your firewall? Is your firewall configured to forward port 25 to your Postfix server?

    Did you check if maybe your ISP is blocking port 25?
     

Share This Page