how to setup IPV6?

Discussion in 'ISPConfig 3 Priority Support' started by craig baker, Jun 24, 2017.

  1. craig baker

    craig baker Member HowtoForge Supporter

    I have had to change my postfix main.cf to disable IPV6 (getting bounces with lines like:
    [email protected]>: connect to alt1.aspmx.l.google.com[2800:3f0:4003:c00::1a]:25: Network is unreachable)

    clearly I'm not setup IPV6 properly so I've changed the inet_interfaces to IPV4 only.

    but - it raises the question how do I ENABLE IPV6 properly? (apart from changing 'IPV4' back to 'all')

    what do I have to have to get postfix to talk properly to google etc?

    and where do I get MY IPV6 address from??
    and how does ISPCONFIG incorporate it in the BIND files etc?

    my ipv4 address is 74.96.241.34

    oh - got the ISPPROTECT problems under control still wish I could find a reference for what a named-malware that you report actually DOES.
    is there not a database somewhere I can look it up and see what the nasty is up to?

    thanks as always
    cdb,
     
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Hello,
    the IPv6 address is assigned to you by your server provider. So if you did not get one from them you cannot set up v6 on the server.

    @ISPProtect: There are so many malware types that it will hardly be possible to list them all in a database. We might build one of the most important entries, but not for now.
     
  3. craig baker

    craig baker Member HowtoForge Supporter

    ok I'll hit verizon FIOS to provide me with some. it turns out that restricting postfix to ipv4 breaks mailman! so I have go to back to all protocols accepted, and I need to fix the ipv6 problem.
    any tutorial on how to install an ipv6 on a running system?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you sure about that? When postfix is listening to IPv4 only and the domains have no IPv6 records then I don't see how mailman can be affected by IPv4 only.

    basically, you will have to edit the network config file and add a section for IPv6. But this differs for the different Linux distributions and might even differ a bit for the network setup used by your ISP. Best is to search for a IPv6 network config guide on the internet for your OS and OS version and to do that search for your ISP as well, it might be that they provide some instructions specific to them.
     
  5. craig baker

    craig baker Member HowtoForge Supporter

    no question ipv4 only in postfix breaks mailman mail posted to list does nothing. nothing gets sent out at all.
    going back to 'both' mailman starts working again.
    also - talked to verizon who says they CANNOT repeat CANNOT give me an ipv6 address!!! so what the heck am I supposed to do? I'm back to getting ipv6 bounces like the one above.
    [email protected]>: connect to alt1.aspmx.l.google.com[2800:3f0:4003:c00::1a]:25: Network is unreachable)

    very frustrating!

    ALSO - on my malware front it seems like my server is NOT getting compromised (I had Wordfence come in and crawl through it. not cheap. wish ISPCONFIG had such a service).
    What is happening is that something tries to upload a file (with the contents mentioned above clearly malicious) and the file is being put in the /tmp folder under one of my main sites (/var/www/clients/client0/web8) and it is not being executed (something fails or is blocked hurray!) - BUT the /tmp files of form phpxxxxx are not being deleted so they are later picked up by ISPPROTECT as malware.
    running centos 6.8, apache2 etc. and these only started appearing fairly recently!
    maybe apache is failing to erase the files when the process fails? not sure where to look.
    Of course I can simply clean out all /tmp/phpxxxx files in a cronjob but would rather fix it 'properly' so I dont get them listed in 'malware detected' email.
    thanks as always
     
  6. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    if mailman requires ipv6, enabled ipv6 in the main.cf and overwrite this in the master.cf for several services.
     
  7. craig baker

    craig baker Member HowtoForge Supporter

    Mailman seemingly knows nothing about ipv6
    Its setting ipv4 only in postfix that breaks it
    Completely repeatable
     

Share This Page