how to setup external mail client to send mail

Discussion in 'Installation/Configuration' started by karalitani, Dec 13, 2011.

  1. karalitani

    karalitani New Member

    i setup a server with this tutorial:

    The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3]

    then i installed roundcube instead of the squirrelmail

    i can send and recieve mail with roundcube (webmail)

    but when i try to setup a desktop email client like thunderbird,
    i can only receive emails i cant send them.

    i believe that i have tried using the submission port,
    but that doesnt work wither,

    any ideas?

    thanks in advance.
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
  3. karalitani

    karalitani New Member

    i figured it out

    i had to un-comment the submission port
    and add the port to the ispconfig firewall.

    that enabled it.

    i also came across another error after i got it working,
    about the file-system when the email client connected.

    i installed the gamin library

    apt-get install gamin

    then i restarted courier services:

    find /etc/init.d/ | grep courier | while read line; do $line restart; done

    and the error went away.

    thanks for your quick reply falko.
  4. pier56

    pier56 Member


    The same problem happens after upgrading to squeeze, keeping ispconfig I have a dedicated server OVH.

    In /var/log/mail.log :
    Dec 31 17:20:02 ks_ postfix/smtpd[7284]: connect from localhost.localdomain[]
    Dec 31 17:20:02 ks_ postfix/smtpd[7284]: lost connection after CONNECT from localhost.localdomain[]
    Dec 31 17:20:02 ks_ postfix/smtpd[7284]: disconnect from localhost.localdomain[]

    Thanks !
    Last edited: Jan 1, 2012
  5. pier56

    pier56 Member

    Precisions :

    • it is possible to send emails to the server
    • it is possible to send mails by smtp server from webmail
    • it is only impossible to use smtp from thunderbird
    And other problem (explained in another post) : now, I can't manage emails accounts by ispconfig.

  6. cbj4074

    cbj4074 Member HowtoForge Supporter

    Okay, so Dovevot/Courier/whatever is working as intended.

    This makes sense, given that the connection is local (no firewalls in the way, etc.)

    Have you even tried taking the same step as karalitani? Try un-commenting the so-called "submission port" in your Postfix configuration and restarting the Postfix service.

    If the port(s) is (are) already open, then try setting your SMTP port in your email client to 587 (plaintext or STARTTLS) or 465 (SSL).

Share This Page