How to setting up webdav within a ispconfig web?

Discussion in 'Installation/Configuration' started by virtualweb, Jul 26, 2006.

  1. virtualweb

    virtualweb New Member

    hi,

    i have a web called "ssl.example.com" and a certificate for that domain.

    ispconfig uses https://ssl.example.com:81

    i created a web "ssl.example.com", it is availiable (over apache2).

    i want to use webdav for that domain (apache2). i tried to put the directives in the directives field but it will be commented out:

    -----
    # DavLockDB /var/log/DavLock/DavLockDB # NOT SUPPORTED!
    # <Location /var/www/ssl.example.com/dav> # NOT SUPPORTED!
    # Dav On # NOT SUPPORTED!
    # </Location> # NOT SUPPORTED!
    -----

    apache -t says "Invalid command 'DavLockDB'".

    what is the correct way to enable webdav?

    tia.
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

  3. yurtboy

    yurtboy New Member

    Web dav

    Got it to work in a non ispconfig with three basic steps
    One..a2enmod dav
    Two..Add line once to httpd.conf
    DAVLockDB /tmp/DAVLock
    Three..
    Add directories
    Alias /ifnl /var/var/www/web10/ifnl_dav
    <Location /ifnaturallearning>
    DAV On
    </Location>
    But I get this error with ISPConfig
    Syntax error on line 6 of /etc/apache2/httpd.conf:
    Invalid command 'DAVLockDB', perhaps mis-spelled or defined by a module not included in the server configuration
    Maybe I need to do it via the ISP Web interface?
    Oh well I will keep trying...
    Also litmus test gives a 450 error if I put the above in the ispconfig for that site and test?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that mod_dav is not loaded. Plese install mod_dav from your linux distribution.
     
  5. yurtboy

    yurtboy New Member

    Loaded?

    Debian/Ubuntu
    a2enmod dav
    Reply
    This module is already enabled! <--it put the explanation point not me.
    But am I doing this in the right place ie not via a place in ISPConfig but in Apache at the console level.
    ????
    Thanks for the reply though.
    PS if anyone has gotten it to work and then create per client settings maybe they could do a how to on this?
     
  6. yurtboy

    yurtboy New Member

  7. falko

    falko Super Moderator ISPConfig Developer

    If it is enabled already, there's no need to add it to /etc/apache2/httpd.conf.

    What's in /etc/apache2/httpd.conf now?
     
  8. yurtboy

    yurtboy New Member

    Well here are some updates....

    Ubuntu having a how to in the forum led to
    One...
    httpd.conf was left alone ie it is default
    Two...
    dav_fs conf looked like this
    root@server1:/etc/apache2/mods-enabled# more dav_fs.conf
    #DAVLockDB /var/lock/apache2/DAVLock
    DAVLockDB /tmp/DAVLock
    #DAVMinTimeout 600
    #Alias /ifnl_dav /var/www/web11/web/aliasfolder/ifnl
    #<Location /ifnl_dav>
    # Dav On
    # AuthType Basic
    # AuthName *username*
    # AuthUserFile /var/www/web11/web/alisfolder/.DAVlogin
    # <LimitExcept PUT GET OPTIONS>
    # Require user *username*
    # </LimitExcept>
    #</Location>
    -----end paste
    BUT even though this did not work I then went into ispconfig and used it's web interface to add this setting to the ONE client I want to have this access.
    Stilll no luck though here is a litmus error
    alfred@alfed:~$ litmus http://domainname/aliasfolder username password
    -> running `basic':
    0. init.................. pass
    1. begin................. FAIL (Could not create new collection `/ifnl/litmus/' for tests: 302 Found
    Server must allow `MKCOL /ifnl/litmus/' for tests to proceed)
    <- summary for `basic': of 2 tests run: 1 passed, 1 failed. 50.0%
    See debug.log for network/debug traces.
    ????
    Thanks in advance
     
  9. yurtboy

    yurtboy New Member

    Done...

    Well almost done...
    Seems if I just focused on the file...
    /etc/apache2/mods-available/dav_fs.conf
    It worked
    For better or for worse I added to /etc/apache2/apache.conf
    BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully
    BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully
    BrowserMatch "Microsoft-WebDAV-MiniRedir/5.1.2600" redirect-carefully
    BrowserMatch "^WebDAVFS" redirect-carefully
    #Header add MS-Author-Via "DAV"
    Since sometimes I had trouble with ms clients
     

Share This Page