How To Set Up A Ubuntu/Debian LAMP Server [domain/test.php] downloads a php file?

Discussion in 'Installation/Configuration' started by husskii, Jan 14, 2010.

  1. husskii

    husskii New Member

    Hi I have been trying to reinstall my LAMP server on one of my virtual machines, & every time I Installing Apache + PHP and create a test.php page something goes wrong, I try access my test.php page from my browser and instead of showing me the test page, it tries to download a php file, and if i download that file and try open it just starts another download...

    Has anyone got any ideas where Im going wrong?
    Ive had this error in the past and was able to overcome it, but I forgot how and am always getting stuck on this section...

    I enjoy using howtoforge tutorials, before howtoforge I knew nothing about linux and as they say learning doesnt come without trial and error lol, I have setup a few vps systems just for these tuts just to teach my self with the help of tutorials like howtoforge.

    Thanks for all the help :)
    Last edited: Jan 14, 2010
  2. falko

    falko Super Moderator ISPConfig Developer

    Which tutorial (URL) did you use to set up the system? Is mod_php enabled? Can you post your vhost configuration?
  3. husskii

    husskii New Member

    all is good now?

    I followed the tut exactly the way it was written, not sure why but a few days later I installed joomla and the test page worked.
    The first 2 times I followed the tutorial it worked perfect, then after that every time I follow the tutorial on one of my servers it tries to download the test.php instead of going to the test page.
    normally I format and start again or try a different howto such as ispconfig (WHICH I'M STILL STUCK ON GETTING ELGG TO WORK)

    anyways this time I just left it and installed joomla on the LAMP server, and as soon as I did that it worked.
    I installed & setup joomla but didnt end up using it, because i didnt like it, so I tried creating a php file and uploaded it to the www folder and now I can see the webpage instead of it trying to download...

    problem solved!!!

    Last edited: Jan 16, 2010

Share This Page