How to set DNS/NS correctly?

Discussion in 'Installation/Configuration' started by ihsir, Apr 27, 2012.

  1. ihsir

    ihsir New Member

    Firstly, this is for a personal website. This is the first time that I've set up a server and am trying to host a site myself.

    All router settings seems fine:
    • I'm able to access ISPConfig via port 8080 (both inside and outside the network).
    • I'm able to SSH into the server using PuTTY (both inside and outside the network).
    • I'm able to access SquirrelMail inside the network.

    In ISPConfig, I have created the Client/Domain/Website/FTP user.

    The Problem:
    I'm not able to FTP into the server with Filezilla or see any of the default index.html pages when I enter the domain name. I figure that it's probably the settings/configuration I have set in GoDaddy and DNSExit.

    In GoDaddy, I've set the 4 nameservers pointing to DNSExit:

    In DNSExit I have the hostname pointing to the home router's IP Address.

    Based on what I know so far, it seems like everything is pointing correctly, so I'm stumped and do not understand why I'm not able to access the site or FTP to the site.

    Does anyone have any pointers, guidance, or suggestions?

  2. pititis

    pititis Member


    Usually with an A record pointing to your IP should work.
    Check port 80 and 21 tcp in your router and server.
    Also try to check if apache y pure-ftp are running. You can check this with:

    netstat -tlpen
  3. ihsir

    ihsir New Member

    Thank you pititis for your quick reply!

    I'm not sure of a few things: how to check port 80 and 21 in the router/server and what am I checking for?
    Hehehe, the same goes for checking apache and pure-ftp.

    I tried restarting apache2:
    root@ubuntu:/# /etc/init.d/apache2 restart
    Syntax error on line 6 of /etc/apache2/conf.d/squirrelmail.conf:
    AddType requires at least two arguments, a mime type followed by one or more file extensions
    Action 'configtest' failed.
    The Apache error log may have more information.!
    I then tried restarting pure-ftpd:
    root@ubuntu:/# /etc/init.d/pure-ftpd-mysql restart
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -H -Y 1 -E -8 UTF-8 -b -O clf:/var/log/pure-ftpd/transfer.log -D -A -u 1000 -B
    Based on this netstat output, I think they're running:
    root@ubuntu:/# netstat -tlpen
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode       PID/Program name
    tcp        0      0  *               LISTEN      0          10922       1937/apache2
    tcp        0      0    *               LISTEN      0          10914       1937/apache2
    tcp        0      0  *               LISTEN      0          10918       1937/apache2
    tcp        0      0    *               LISTEN      0          1863385     23369/pure-ftpd (SE
    tcp        0      0*               LISTEN      108        8750        960/named
    tcp        0      0  *               LISTEN      108        8748        960/named
    tcp        0      0    *               LISTEN      0          1009702     18836/master
    tcp        0      0 *               LISTEN      108        8753        960/named
    tcp        0      0   *               LISTEN      0          10916       1937/apache2
    tcp        0      0*               LISTEN      107        8987        1105/amavisd (maste
    tcp        0      0*               LISTEN      0          1009488     18836/master
    tcp        0      0  *               LISTEN      104        1676896     22524/mysqld
    tcp        0      0 *               LISTEN      0          8535        816/sshd
    tcp6       0      0 :::21                   :::*                    LISTEN      0          1863387     23369/pure-ftpd (SE
    tcp6       0      0 :::53                   :::*                    LISTEN      108        8743        960/named
    tcp6       0      0 ::1:953                 :::*                    LISTEN      108        8754        960/named
    tcp6       0      0 :::993                  :::*                    LISTEN      0          9518        1681/couriertcpd
    tcp6       0      0 :::995                  :::*                    LISTEN      0          10606       1731/couriertcpd
    tcp6       0      0 :::22                   :::*                    LISTEN      0          8537        816/sshd
    tcp6       0      0 :::110                  :::*                    LISTEN      0          9527        1703/couriertcpd
    tcp6       0      0 :::143                  :::*                    LISTEN      0          9514        1653/couriertcpd
    So, does this look correct?
  4. ihsir

    ihsir New Member

    After a lot of help from pititis, here are the steps taken to solve the problem:

    I followed instructions from and I opened the ports in the router, added the port range to the firewall in IPConfig (System > Firewall), enabled the PassivePortRange on the server (using the links above) and it seems that I can access everything now!

    Also, in Filezilla, I was setting the port to 22 (like how I did for SSH with PuTTY). This was incorrect -- it needed to be blank and set to normal FTP with explicit TLS.

    Many thanks HowToForge and Many many thanks pititis!
  5. pititis

    pititis Member

    Glad to help you!
  6. ihsir

    ihsir New Member

    FTP not working again...

    After shutting off the computer for a little over a week, I'm again having some issues with FTP'ing into the machine from Filezilla.

    Status:	Resolving address of site.domainName
    Status:	Connecting to ipAddressOfMachine:21...
    Status:	Connection established, waiting for welcome message...
    Response:	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:	220-You are user number 1 of 50 allowed.
    Response:	220-Local time is now 13:07. Server port: 21.
    Response:	220-This is a private system - No anonymous login
    Response:	220-IPv6 connections are also welcome on this server.
    Response:	220 You will be disconnected after 15 minutes of inactivity.
    Command:	AUTH TLS
    Response:	234 AUTH TLS OK.
    Status:	Initializing TLS...
    Error:	Could not connect to server
    My Filezilla settings:
    Host: site.domainName
    Port: empty
    Protocol: FTP - File Transfer Protocol
    Encryption: Require explicit FTP over TLS
    Logon Type: Normal
    User: userName
    Password: password

    Under the Advanced type, I've tried setting the OS to both Autodetect and to Unix.

    How to tell what is wrong, and how to go about fixing it?

  7. falko

    falko Super Moderator ISPConfig Developer

    Do you have many special chars in your password? It might be that FileZilla has problems with it (just had this yesterday...).

Share This Page