How to see the Sites on ISPConfig3

Discussion in 'Installation/Configuration' started by mezelf, Jan 4, 2022.

  1. mezelf

    mezelf New Member

    Hi there,
    I have upgraded my ISPConfig3 to the current latest version (3.2.7p1).
    I can't seem to find the `Sites' menu option. Though on the home page I see a read-only list of Domain/Websites, email addresses etc.
    When I try to list Clients (with the hope of navigating from there to Sites), I see no clients, although I know that I have one (client0).
    When I read the post `Please read before posting!' in this forum, it mentions under 'Something is not working after updating ISPConfig' that 'Did you let the update script reconfigure your services? If not, run a forced update and let it reconfigure services with...'. I did that allowed reconfiguration of services. But still not seeing any clients to navigate to the sites.
    Am I looking at the wrong place?
    Thanks.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Did things work before upgrading? Are you logged in as admin? Do you have Sites module enabled under System > CP Users > {your username}? If you haven't tried already, logout and clear your browser cache, then login again.
     
    mezelf likes this.
  3. mezelf

    mezelf New Member

    Thank you for your reply.
    Yes I am logged in as admin. I have checked the modules enabled. All are enabled. But some are visible in the menu (monitor, client, help tools etc) but some (sites, dns etc) are not visible. In the modules, all the boxes are filled in.
    I have logged out. Restarted the firefox browser. Cleared the caches of the browser. Re-logged in. The same issue.
    Before the update, I was able to add email addresses etc I am sure because there is an email address that I have added just before the update. It is being displayed in read only section on the home page.
    The strange thing is, at least the Clients module is on and should I not be able to see at least the existing client (client0)?
    regards.
     
    Last edited: Jan 5, 2022
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    mezelf likes this.
  5. mezelf

    mezelf New Member

    Thank you for your reply. I had gone through the `Please read before posting!' post and checked things which I thought were relevant for my situation. Namely the 'Something is not working after updating ISPConfig' that 'Did you let the update script reconfigure your services?. I realized that I did not mention my OS & PHP versions.
    Debian 10.11
    PHP 7.3
    PHP CGI 7.3
    regards.
     
  6. mezelf

    mezelf New Member

    To add: When I look at the web directories I see the hierarchy /var/www/clients/client0/web... So there is one client...
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    That's quite strange indeed. May you please post a screenshot of the settings of the admin user under System > CP users ? And then take a look at the file /usr/local/ispconfig/interface/lib/config.inc.php check the lines:

    Code:
    $conf['modules_available'] = 'dashboard,admin,mail,sites,monitor,client,dns,help';
    $conf['interface_modules_enabled'] = 'dashboard,mail,sites,dns,tools,help';
    if they are there and look like the above. and please post the result of:

    ls -la /usr/local/ispconfig/interface/web/
     
    mezelf likes this.
  8. mezelf

    mezelf New Member

    Thank you for your reply.

    ls -la /usr/local/ispconfig/interface/web/ result is:
    Code:
    total 112
    drwxr-x--- 19 ispconfig ispconfig 4096 May 12  2021 .
    drwxr-x---  9 ispconfig ispconfig 4096 May 12  2021 ..
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 admin
    -rwxr-x---  1 ispconfig ispconfig 3212 Jan  4 22:46 capp.php
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 client
    -rwxr-x---  1 ispconfig ispconfig 2970 Jan  4 22:46 content.php
    drwxr-x---  7 ispconfig ispconfig 4096 May 12  2021 dashboard
    -rwxr-x---  1 ispconfig ispconfig 1901 Jan  4 22:46 datalogstatus.php
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 dns
    -rwxr-x---  1 ispconfig ispconfig    0 Jan  4 22:46 dummy_login.html
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 help
    -rwxr-x---  1 ispconfig ispconfig 4533 Jan  4 22:46 index.php
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 js
    -rwxr-x---  1 ispconfig ispconfig 1649 Jan  4 22:46 keepalive.php
    drwxr-x---  4 ispconfig ispconfig 4096 May 12  2021 login
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 mail
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 mailuser
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 monitor
    -rwxr-x---  1 ispconfig ispconfig 5177 Jan  4 22:46 nav.php
    drwxr-x---  2 ispconfig ispconfig 4096 May 12  2021 remote
    -rwxr-x---  1 ispconfig ispconfig   26 Jan  4 22:46 robots.txt
    drwxr-x---  7 ispconfig ispconfig 4096 May 12  2021 sites
    drwxr-x---  3 ispconfig ispconfig 4096 May 12  2021 strengthmeter
    drwxrwx---  2 ispconfig ispconfig 4096 May 12  2021 temp
    drwxr-x---  3 ispconfig ispconfig 4096 May 12  2021 themes
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 tools
    drwxr-x---  6 ispconfig ispconfig 4096 May 12  2021 vm
    
    The home page looks like this:
    [​IMG] https://imgur.com/a/ACUFNgO [/IMG]
    [​IMG]
    And the admin settings page:
    [​IMG]
    [​IMG] https://imgur.com/a/BsamKEn [/IMG]

    regards.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, looks fine so far. Please post the result of:

    ls -la /usr/local/ispconfig/interface/web/sites/lib/
     
    mezelf likes this.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    And the two lines I posted from /usr/local/ispconfig/interface/lib/config.inc.php file look the same on your system?
     
    mezelf likes this.
  11. mezelf

    mezelf New Member

    My apologies!
    Yes I had checked them too and they look the same!
    Code:
    //** Server
    $conf['app_title'] = ISPC_APP_TITLE;
    $conf['app_version'] = ISPC_APP_VERSION;
    $conf['app_link'] = 'https://www.ispconfig.org/';
    $conf['modules_available'] = 'dashboard,admin,mail,sites,monitor,client,dns,help';
    $conf['server_id'] = '1';
    $conf['init_scripts'] = '/etc/init.d';
    
    //** Interface
    $conf['interface_modules_enabled'] = 'dashboard,mail,sites,dns,tools,help';
    
    regards.
     
  12. mezelf

    mezelf New Member

    And
    Code:
     ls -la /usr/local/ispconfig/interface/web/sites/lib/
    total 84
    drwxr-x--- 3 ispconfig ispconfig  4096 May 12  2021 .
    drwxr-x--- 7 ispconfig ispconfig  4096 May 12  2021 ..
    -rwxr-x--- 1 ispconfig ispconfig     9 Jan  4 22:46 admin.conf.php
    drwxrwx--- 2 ispconfig ispconfig 61440 May 12  2021 lang
    -rwxr-x--- 1 ispconfig ispconfig  6518 Jan  4 22:46 module.conf.php
    -rwxr-x--- 1 ispconfig ispconfig  1965 Jan  4 22:46 remote.conf.php
    [email protected]:/usr/local/ispconfig/interface/lib#
    
    regards.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    This is looking fine as well. I'm getting a bit out of ideas at the moment .... I'll have to look at the code to see under which exact conditions a module gets hidden in the menu. Maybe @Jesse Norell or @Th0m have another idea.
     
    mezelf likes this.
  14. mezelf

    mezelf New Member

    Thank you for your reply.
    I do not recall exactly what my previous version was. I am thinking maybe 3.1. I wonder if I had to upgrade in steps like first to 3.2 and then to the current version. Anyways I have just downloaded the manual and I shall check if I am missing something in general.
    regards.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    There are no special steps required, doing an upgrade from a 3.1 to latest 3.2 version should work without issues. The problem you encounter is so uncommon that I don't remember that we ever had it, so I'll have to further check the code to get a full list of conditions under which a module might become hidden.
     
    mezelf likes this.
  16. mezelf

    mezelf New Member

    Thank you.
    regards.
     
  17. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    It wouldn't hurt to check your browser console for any errors, though I don't know that an error there would cause just one menu item to hide. Try private browser mode to ensure no browser plugins are interfering. Check error logs (web server and php) and see if anything shows up. That's all that comes to mind, short of tracing code and checking db table values.
     

Share This Page