How to recovery after OS/Ispconfig3 reinstall

Discussion in 'Installation/Configuration' started by Monotoba, Aug 21, 2012.

  1. Monotoba

    Monotoba Member

    I was doing an OS update from Ubuntu 11.14 to 12.04 and the system frooze. After waiting an hour or more I had no choice but to turn the machine off (sysreq did not respond). On power up the system failed to boot. I put the drive in another machine and copied the drive contents (file copy) and did a dd image of each partition. I then spent two days trying to work out the bugs of a partial upgrade and eventually gave up. I reinstalled starting with Ubuntu 10.04 (as was the original OS and then proceeded to do all updates and upgrades. I am now back to 11.10 and trying to get ISPConfig3 to let me log in.

    I was able to log in until I replaced the database with the one I copied from the original install. I can access the database via phpmyadmin and I have tried resetting the admin password using md5 encrypt. I get the login screen but logging in with any user fails fails. I used all the same usernames and passwords when I reinstalled everything so as not to have to redocument everything.

    At this time I can get into phpmyadmin (all databases), and I can get the ispconfig login page. But I cannot log in and all other hosted site result in the default apache page
  2. Monotoba

    Monotoba Member

    I see lots of lookers but no takers on this issue. How can I help you guys help me?

    I am not getting any errors other than not being able to log in to ispconfig3.
    so if I have not posted any needed info it is because I can't find any errors other than failed logins. And I have updated the sys_user table many times and even
    tried md5, sha1 and password encoding the admin password.

    So where should I start looking if resetting the admin password results in failure to login?
    Could it be a database error or would that result in a db error message from ispconfig? Could there be a salt value that has changed that is not allowing ispconf to recognize the password? I am grabbing at straws here, looking for any kind of clue! If you think you might have an idea let me know please!!!

    Thanks for reading
    Last edited: Aug 22, 2012
  3. Monotoba

    Monotoba Member

    Login Issue update

    Ok, adding a few print statements in key places in the login php script tells me that the user query: $sql = "SELECT * FROM sys_user WHERE USERNAME = '$username'";
    $user = $app->db->queryOneRecord($sql);

    is returning a bool false value and not an array or object. I suspect this maybe a user access issue in the db? Any ideas? One thing I do know I changed was the hostname. Could this be the cause?
  4. Monotoba

    Monotoba Member

    Given up!

    Ok, I worked through the night last night and I figured out the db wasn't connecting for the sites. But alas, it just seems simpler to manually recreate everything. I'm not sure what good the db and site backups are if it doesn't allow me to re-install the system without manually recreating everything... my regular file copy backups seem to handle preserving the files.
  5. Monotoba

    Monotoba Member

    Fixing open_basedir with CodeIgniter

    Hi all,

    I am having to rebuild my server manually and I came across an issue. all my Code Igniter sites are receiving an open_basedir error. The sites have the application and system directories set as siblings under the parent web? directory. i.e.:


    I have the following line in the PHP open_basedir option: /var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/[CUT-SITENAME]/web:/srv/www/[CUT - SITENAME]/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php

    So how do I need to change this to make things work correctly?

    Thanks for te help.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. Monotoba

    Monotoba Member

    Sorry I didn't intend to but once I realized this message got posted here instead of in a new thread I couldn't find a way to remove it....

Share This Page