How to re-assign ftp default upload location

Discussion in 'Installation/Configuration' started by rlntel, Sep 26, 2014.

  1. rlntel

    rlntel New Member

    Noob question...

    ISPConfig is set up properly.

    When I browse to the IP or site name, Apache's index page displays from /var/www/html. I've even vi-ed a phpinfo file to /var/www/html and am able to see it from the browser.

    However...when I connect to the IP or site name with Filezilla, it connects to /home/administrator, and I can't get to it from the browser.

    How do I get Filezilla to connect to /var/www/html?

    Thanks in advance.
  2. srijan

    srijan New Member HowtoForge Supporter

    How did you created the ftp user?
    USe this method to create the ftp-user, in ISPConfig webinterface
    Goto Sites-->Ftp-accounts-->Add ftp client

    Then add the entries with username and password, just there in second tab Options-->Directory default path will come, it can be customized as per your choice.

    Simply install filezilla and connect with defaultftpusername and password.
    It works very smoothly
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    you use a wrong file location. Please do this:

    1) Add your IP address in ispconfig under System > Server IP.
    2) Create a website in ispconfig and select the server IP.
    3) Add a FTP user in ispconfig and upload your website data into the /web directory of the site with that ftp user.

    The folder /var/www/html and /home/administratorare not used on a ispconfig server. You just get there beacuse you did not do the above steps yet.

Share This Page