How to proper Dns , please help .

Discussion in 'HOWTO-Related Questions' started by Dameats1, Nov 22, 2019.

  1. Dameats1

    Dameats1 New Member

    Ubuntu 18 .04
    server set up with the perfect server , ISPCONFIG tutorial.
    my level of knowledge noob.

    I have this server up an running under domain mydomain.com pointing to my public ip subsequently pointing to my ipv4 192.168.1.1.
    everything in that one is working correctly. Now i installed virtual box and set up a media server on it. I registered for another domain, movies.com. and its also pointing to my public Ip. So what are the proper steps to configure my server so when is asked for movies.com redirects to ipv4 192.168.1.2 instead of the one from mydomain.com ??

    i tried setting up a Dns where zone is movies.com and ipv4 is 192.168.1.2 but still when i tries to access remotely it redirects to mydomain.com.

    Please help my to understand how to resolve this?
     
  2. Dameats1

    Dameats1 New Member

    I think is reverse proxy what i need to do ... any suggestions ?
     
  3. Steini86

    Steini86 Active Member

    Depends on the service you want to use. You can also use your firewall to forward a port from the server to your virtual machine. You might want to have a look at https://traefik.io/
     
  4. ahrasis

    ahrasis Well-Known Member

    This is wrong since ISPConfig setup requires subdomain.mydomain.com. Command hostname -f should always show subdomain.mydomain.com.
     
    Last edited: Nov 23, 2019
  5. Dameats1

    Dameats1 New Member

    thank you very much both for taking your time to help me ......
    i have my web server and cloud running on ubuntu 18.04 ispconfig . under a domain (mydomain.com)
    i installed openflixr in virtual box and i pretend to use the domain (movies.com)
    but when i externally i access movies.com it shows me the content of my domain .com

    Traefik seems to be the answer! im gonig to try it .

    im sorry if im so noob.
     
  6. Steini86

    Steini86 Active Member

    If it is already setup, and you only want to proxy your webpage, then just use apache with mod_proxy (maybe needs to be enabled with "a2enmod proxy"):

    Configure the domain in ispconfig and in options -> apache directive add:
    Code:
    ProxyPreserveHost On
    ProxyPass /.well-known !
    ProxyPass / http://192.168.1.2/
    ProxyPassReverse / http://192.168.1.2/
    You will find additional information on what each line does at https://httpd.apache.org/docs/2.4/mod/mod_proxy.html
     

Share This Page