How to prevent a FTP user see the tree folder of Ubuntu 14.04 server?

Discussion in 'Installation/Configuration' started by glardone, Oct 30, 2015.

  1. glardone

    glardone New Member

    Dear all,
    before writing here, I tried a lot, but I have not found an answer... :(
    I have an Ubuntu 14.04 server with the latest version of ISPConfig 3 + Pure-FTPD + Jaillkit.
    The Users access via sftp to their web hosting and the login works correctly, however, each user sees (not write) the whole tree folder from root directory and not only his home web root.
    For example: /var/www/clients/client4/web88 and not only /web88

    Someone had the same problem or know how to solve it?
    Thank you!
  2. concept21

    concept21 Member

    Just set a sub directory in his ftp set up page, for example:
  3. glardone

    glardone New Member

    Uhm... I do not use the FTP session in "Web Access -> FTP-Accounts", but "Command Line -> Shell User" to provide access in SFTP and not in FTP mode, and the "Base Dir" in "Options" tab is correct , for example "/var/www/clients/client15/web117".
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so you don't use FTP at all. A connection by SSH is not FTP, thats either SCP or SFTP which are both protocols handled by sshd and not FTP. If you want to have a jailed ssh account then activate the jail in the ssh user. Or use FTP or FTPS (FTP over TLS) instead of the SSH protocols SCP and SFTP as FTP logins are jailed by default.

Share This Page