how to permormace Apache server with ispconfig?

Discussion in 'Server Operation' started by mart28, Nov 10, 2016.

  1. mart28

    mart28 New Member

    Hello
    I have a debian 8 server with ispconfig.
    I have updated php 7 following this tutorial.
    https://www.howtoforge.com/tutorial/how-to-install-php-7-on-debian/
    I wanted to optimize apache but if I change I do not see any changes when doing a benchmark test.
    I always get + -.

    I do not know what I'm doing wrong

    I select in ispconfig php-fpm version 7


    Concurrency Level: 1
    Time taken for tests: 37.119 seconds
    Complete requests: 25
    Failed requests: 24
    (Connect: 0, Receive: 0, Length: 24, Exceptions: 0)
    Total transferred: 894661 bytes
    HTML transferred: 887561 bytes
    Requests per second: 0.67 [#/sec] (mean)
    Time per request: 1484.772 [ms] (mean)
    Time per request: 1484.772 [ms] (mean, across all concurrent requests)
    Transfer rate: 23.54 [Kbytes/sec] received
    Connection Times (ms)
    min mean[+/-sd] median max
    Connect: 0 0 0.0 0 0
    Processing: 1288 1484 551.5 1322 4090
    Waiting: 1267 1463 551.2 1300 4068
    Total: 1288 1485 551.5 1322 4090
    Percentage of the requests served within a certain time (ms)
    50% 1321
    66% 1450
    75% 1477
    80% 1498
    90% 1513
    95% 1628
    98% 4090
    99% 4090
    100% 4090 (longest request)

    apache2ctl -V | grep -i mpm
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:69
    Server MPM: prefork

    # apache2 -l
    Compiled in modules:
    core.c
    mod_so.c
    mod_watchdog.c
    http_core.c
    mod_log_config.c
    mod_logio.c
    mod_version.c
    mod_unixd.c

    ps aux | grep php-fpm
    root 743 0.0 0.4 135516 8936 ? Ss nov09 0:03 php-fpm: master process (/opt/php-7.0.7/etc/php-fpm.conf)
    www-data 1260 0.0 0.1 135516 3700 ? S nov09 0:00 php-fpm: pool w ww
    www-data 1261 0.0 0.1 135516 3700 ? S nov09 0:00 php-fpm: pool w ww
    root 1460 0.0 1.2 453384 24684 ? Ss nov09 0:04 php-fpm: master process (/etc/php5/fpm/php-fpm.conf)
    www-data 1478 0.0 0.4 453384 8324 ? S nov09 0:00 php-fpm: pool w ww
    www-data 1479 0.0 0.4 453384 8324 ? S nov09 0:00 php-fpm: pool w ww
    root 23564 0.0 0.0 14436 972 pts/0 S+ 11:52 0:00 grep php-fpm

    The directory where I change the configuration is

    /etc/apache2/mods-available
    mem_prefork.config

    IfModule mpm_prefork_module>
    StartServers 5
    MinSpareServers 20
    MaxSpareServers 60
    MaxRequestWorkers 60
    MaxConnectionsPerChild 300


    and
    /opt/php-7.0.7/etc/php-fpm.d


    I have tried in
    www.conf
    and
    Web8.conf (this is the number of the web in ispconfig)
    in here
    I read


    [web8]
    listen = /var/lib/php5-fpm/web8.sock
    listen.owner = web8
    listen.group = www-data
    listen.mode = 0660
    user = web8
    group = client3
    pm = dynamic
    pm.max_children = 10
    pm.start_servers = 2
    pm.min_spare_servers = 1
    pm.max_spare_servers = 5
    pm.max_requests = 0


    service apache2 restart
    service php7.0.7-fmp restart
    servide php5-fpm restart

    If I make a php.info

    PHP Version 7.0.7
    Server API FPM/FastCGI
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /opt/php-7.0.7/lib
    Loaded Configuration File /opt/php-7.0.7/lib/php.ini



    [web8]
    listen = /var/lib/php5-fpm/web8.sock
    Should it be php 7?


    My ram consumption by the apache processes are about 12 mega + -
    The server is a kimsufi with 2Gb of ram

    Thank you
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The performance of apache with ispconfig is exactly the same than using apache without ispconfig, ispconfig has no influence on the performance of the web server.

    While you can change php-fpm settings in the php-fpm config file, it does not make much sense to do thata s you changes will get removed as soon as you edit the site again in ispconfig. better use the php-fpm settings on the options tab of the website in ispconfig.
     
  3. mart28

    mart28 New Member

    Thanks tilt

    I'm doing something wrong, because when I do a test test it tells me this

    Concurrency Level: 1
    Time taken for tests: 37.119 seconds
    Complete requests: 25
    Failed requests: 24
    (Connect: 0, Receive: 0, Length: 24, Exceptions: 0)
    Total transferred: 894661 bytes
    HTML transferred: 887561 bytes
    Requests per second: 0.67 [#/sec] (mean)
    Time per request: 1484.772 [ms] (mean)
    Time per request: 1484.772 [ms] (mean, across all concurrent requests)
    Transfer rate: 23.54 [Kbytes/sec] received
    Connection Times (ms)
    min mean[+/-sd] median max
    Connect: 0 0 0.0 0 0
    Processing: 1288 1484 551.5 1322 4090
    Waiting: 1267 1463 551.2 1300 4068
    Total: 1288 1485 551.5 1322 4090
    Percentage of the requests served within a certain time (ms)
    50% 1321
    66% 1450
    75% 1477
    80% 1498
    90% 1513
    95% 1628
    98% 4090
    99% 4090
    100% 4090 (longest request)



    But if I enter the website it takes about 10 seconds to load
    If I use gtmetrix and do several tests I get this

    Page Load Time
    12.1s


    In some occasion after finishing a test if I go gt metrix, give 404 error? I do not remember
    And if I repeat the test, tell me this.

    ..apr_pollset_poll: The timeout specified has expired (70007)



    I change
    PHP-FPM pm.max_children .....
    Via ispconfig web options

    I use 1 1 1 1 1

    20 20 20 20 20
    20 5 2 1 5
    ....

    If I change php-fpm for fast cgi times change
    Do you know of any online site to run an online test or another test easy to use?
    Thank you
     

Share This Page